Updated AUTHORS file.
[debian/gnuradio] / config / grc_gr_audio_alsa.m4
index c1d88b9e43df706b68c19cf10ec78638a745b583..6304f4f30e3acd8ea3c82146fd808f0a3e200825 100644 (file)
@@ -14,11 +14,11 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_ALSA],[
-    AC_CONFIG_SRCDIR([gr-audio-alsa/src/audio_alsa.i])
+    GRC_ENABLE([gr-audio-alsa])
 
     AC_CONFIG_FILES([ \
        gr-audio-alsa/Makefile \
@@ -26,16 +26,13 @@ AC_DEFUN([GRC_GR_AUDIO_ALSA],[
        gr-audio-alsa/src/run_tests \
     ])
 
-    succeeded=yes
-    PKG_CHECK_MODULES(ALSA, alsa >= 0.9,[],[succeeded=no])
-    if test $succeeded = yes; then
-        LIBS="$LIBS $ALSA_LIBS"
+    passed=yes
+    PKG_CHECK_MODULES(ALSA, alsa >= 0.9,[],
+        [passed=no;AC_MSG_RESULT([gr-audio-alsa requires package alsa, not found.])])
 
+    GRC_BUILD_CONDITIONAL([gr-audio-alsa],[
+       AC_SUBST(ALSA_LIBS)
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_alsa], [chmod +x gr-audio-alsa/src/run_tests])
-        subdirs="$subdirs gr-audio-alsa"
-    else
-       AC_MSG_RESULT([failed: $ALSA_PKG_ERRORS])
-       failed="$failed gr-audio-alsa"
-    fi
+    ])
 ])