Fix missing files in distribution tarball (Dan Halperin).
[debian/gnuradio] / config / grc_gnuradio_examples.m4
index bc27f2a7b449033e52d10e33cfc7e67b12878063..5dc6caf0a25bf2ad8eec021dfe7034553b80c8a3 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+# Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -22,29 +22,28 @@ AC_DEFUN([GRC_GNURADIO_EXAMPLES],[
 
     AC_CONFIG_FILES([ \
         gnuradio-examples/Makefile \
+       gnuradio-examples/c++/Makefile \
         gnuradio-examples/python/Makefile \
         gnuradio-examples/python/apps/hf_explorer/Makefile \
         gnuradio-examples/python/apps/hf_radio/Makefile \
         gnuradio-examples/python/apps/Makefile \
         gnuradio-examples/python/audio/Makefile \
-        gnuradio-examples/python/channel-coding/Makefile \
-        gnuradio-examples/python/channel-coding/fsm_files/Makefile \
+       gnuradio-examples/python/dect/Makefile \
         gnuradio-examples/python/digital/Makefile \
         gnuradio-examples/python/digital_voice/Makefile \
-       gnuradio-examples/python/hier/Makefile \
-       gnuradio-examples/python/hier/audio/Makefile \
-       gnuradio-examples/python/hier/networking/Makefile \
-       gnuradio-examples/python/hier/digital/Makefile \
-       gnuradio-examples/python/hier/dect/Makefile \
-       gnuradio-examples/python/hier/ofdm/Makefile \
-       gnuradio-examples/python/hier/sounder/Makefile \
-       gnuradio-examples/python/hier/usrp/Makefile \
         gnuradio-examples/python/multi-antenna/Makefile \
         gnuradio-examples/python/multi_usrp/Makefile \
-        gnuradio-examples/python/networking/Makefile \
+        gnuradio-examples/python/network/Makefile \
+       gnuradio-examples/python/ofdm/Makefile \
         gnuradio-examples/python/usrp/Makefile \
     ])
 
     passed=yes
+    # Don't do gnuradio-examples if gnuradio-core skipped
+    if test x$gnuradio_core_skipped = xyes; then
+        AC_MSG_RESULT([Component gnuradio-examples requires gnuradio-core, which is not being built or specified via pre-installed files.])
+        passed=no
+    fi
+
     GRC_BUILD_CONDITIONAL([gnuradio-examples])
 ])