Merged r5566:5676 from jcorgan/snd into trunk, with minor changes. Component gr...
[debian/gnuradio] / config / grc_gnuradio_core.m4
index 9fab4c2a850884ddd2d77aea8346c80db2ce6478..ebf0738dcabb906eda3c4bba91d073be48421ff0 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2007 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -14,8 +14,8 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GNURADIO_CORE],[
     GRC_ENABLE([gnuradio-core])
@@ -34,9 +34,9 @@ AC_DEFUN([GRC_GNURADIO_CORE],[
         gnuradio-core/src/lib/g72x/Makefile \
         gnuradio-core/src/lib/general/Makefile \
         gnuradio-core/src/lib/general/gr_prefix.cc \
+        gnuradio-core/src/lib/gengen/Makefile \
         gnuradio-core/src/lib/io/Makefile \
         gnuradio-core/src/lib/missing/Makefile \
-        gnuradio-core/src/lib/omnithread/Makefile \
         gnuradio-core/src/lib/reed-solomon/Makefile \
         gnuradio-core/src/lib/runtime/Makefile \
         gnuradio-core/src/lib/swig/Makefile \
@@ -45,6 +45,8 @@ AC_DEFUN([GRC_GNURADIO_CORE],[
         gnuradio-core/src/python/gnuradio/Makefile \
         gnuradio-core/src/python/gnuradio/blks/Makefile \
         gnuradio-core/src/python/gnuradio/blksimpl/Makefile \
+        gnuradio-core/src/python/gnuradio/blks2/Makefile \
+        gnuradio-core/src/python/gnuradio/blksimpl2/Makefile \
         gnuradio-core/src/python/gnuradio/gr/Makefile \
         gnuradio-core/src/python/gnuradio/gr/run_tests \
         gnuradio-core/src/python/gnuradio/gru/Makefile \
@@ -54,11 +56,27 @@ AC_DEFUN([GRC_GNURADIO_CORE],[
     ])
     
     passed=yes
+    # Don't do gnuradio-core if omnithread skipped
+    # There *has* to be a better way to check if a value is in a string
+    for dir in $skipped_dirs
+    do
+       if test x$dir = xomnithread; then
+           AC_MSG_RESULT([Component gnuradio-core requires omnithread, which is not being built.])
+           passed=no
+       fi
+    done
+
     GRC_BUILD_CONDITIONAL([gnuradio-core],[
         dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_core], [chmod +x gnuradio-core/src/python/gnuradio/gr/run_tests])
 
-        dnl kludge up initial swig dependency file
-        AC_CONFIG_COMMANDS([swig_deps], [touch gnuradio-core/src/lib/swig/gnuradio_swig_python.d])
+        dnl kludge up initial swig dependency files
+        AC_CONFIG_COMMANDS([swig_deps],        [
+               touch gnuradio-core/src/lib/swig/gnuradio_swig_py_runtime.d
+               touch gnuradio-core/src/lib/swig/gnuradio_swig_py_general.d
+               touch gnuradio-core/src/lib/swig/gnuradio_swig_py_gengen.d
+               touch gnuradio-core/src/lib/swig/gnuradio_swig_py_filter.d
+               touch gnuradio-core/src/lib/swig/gnuradio_swig_py_io.d
+               ])
     ])
 ])