Merged r6224:6268 from features/deb into trunk. Implements most of a Debian package...
[debian/gnuradio] / config / grc_gnuradio_core.m4
index 53997c6d3bd7c6dc85a16dd2af58b2cf78b5fcc6..af83cb6a57850572cb89a42ce73d282b21f91b75 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2007 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -34,9 +34,9 @@ AC_DEFUN([GRC_GNURADIO_CORE],[
         gnuradio-core/src/lib/g72x/Makefile \
         gnuradio-core/src/lib/general/Makefile \
         gnuradio-core/src/lib/general/gr_prefix.cc \
+        gnuradio-core/src/lib/gengen/Makefile \
         gnuradio-core/src/lib/io/Makefile \
         gnuradio-core/src/lib/missing/Makefile \
-        gnuradio-core/src/lib/omnithread/Makefile \
         gnuradio-core/src/lib/reed-solomon/Makefile \
         gnuradio-core/src/lib/runtime/Makefile \
         gnuradio-core/src/lib/swig/Makefile \
@@ -45,6 +45,8 @@ AC_DEFUN([GRC_GNURADIO_CORE],[
         gnuradio-core/src/python/gnuradio/Makefile \
         gnuradio-core/src/python/gnuradio/blks/Makefile \
         gnuradio-core/src/python/gnuradio/blksimpl/Makefile \
+        gnuradio-core/src/python/gnuradio/blks2/Makefile \
+        gnuradio-core/src/python/gnuradio/blksimpl2/Makefile \
         gnuradio-core/src/python/gnuradio/gr/Makefile \
         gnuradio-core/src/python/gnuradio/gr/run_tests \
         gnuradio-core/src/python/gnuradio/gru/Makefile \
@@ -54,11 +56,27 @@ AC_DEFUN([GRC_GNURADIO_CORE],[
     ])
     
     passed=yes
+    # Don't do gnuradio-core if omnithread skipped
+    # There *has* to be a better way to check if a value is in a string
+    for dir in $skipped_dirs
+    do
+       if test x$dir = xomnithread; then
+           AC_MSG_RESULT([Component gnuradio-core requires omnithread, which is not being built.])
+           passed=no
+       fi
+    done
+
     GRC_BUILD_CONDITIONAL([gnuradio-core],[
         dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_core], [chmod +x gnuradio-core/src/python/gnuradio/gr/run_tests])
 
-        dnl kludge up initial swig dependency file
-        AC_CONFIG_COMMANDS([swig_deps], [touch gnuradio-core/src/lib/swig/gnuradio_swig_python.d])
+        dnl kludge up initial swig dependency files
+        AC_CONFIG_COMMANDS([swig_deps],        [
+               touch gnuradio-core/src/lib/swig/gnuradio_swig_py_runtime.d
+               touch gnuradio-core/src/lib/swig/gnuradio_swig_py_general.d
+               touch gnuradio-core/src/lib/swig/gnuradio_swig_py_gengen.d
+               touch gnuradio-core/src/lib/swig/gnuradio_swig_py_filter.d
+               touch gnuradio-core/src/lib/swig/gnuradio_swig_py_io.d
+               ])
     ])
 ])