cobble a temporary changelog entry to keep this test build straight
[debian/gnuradio] / config / grc_gcell.m4
index 188437f0481bf9e44bad5e278a02e0f4bc7be892..b94deb4db465ea1a10cf6388d5ae813360ea9b45 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008,2010 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -21,11 +21,6 @@ AC_DEFUN([GRC_GCELL],[
     GRC_ENABLE(gcell)
     dnl GRC_WITH(gcell)
 
-    dnl Don't do gcell if omnithread or mblock skipped
-    dnl (The mblock dependency should be refactored, we're just using some timing utilities)
-    GRC_CHECK_DEPENDENCY(gcell, omnithread)
-    GRC_CHECK_DEPENDENCY(gcell, mblock)
-
     dnl If execution gets to here, $passed will be:
     dnl   with : if the --with code didn't error out
     dnl   yes  : if the --enable code passed muster and all dependencies are met
@@ -52,40 +47,30 @@ AC_DEFUN([GRC_GCELL],[
 
     if test $passed != with; then
        dnl how and where to find INCLUDES and LA
-       gcell_INCLUDES="-I\${abs_top_srcdir}/gcell/src/include \
-                -I\${abs_top_srcdir}/gcell/src/lib/runtime \
-                -I\${abs_top_srcdir}/gcell/src/lib/general \
-                -I\${abs_top_srcdir}/gcell/src/lib/wrapper"
-        gcell_LA="\${abs_top_builddir}/gcell/src/lib/libgcell.la"
-       gcell_spu_INCLUDES="-I\${abs_top_srcdir}/gcell/src/include/spu \
-                -I\${abs_top_srcdir}/gcell/src/include \
-                -I\${abs_top_srcdir}/gcell/src/lib/runtime/spu \
-                -I\${abs_top_srcdir}/gcell/src/lib/general/spu \
-                -I\${abs_top_srcdir}/gcell/src/lib/wrapper/spu"
-       gcell_spu_LA="\${abs_top_builddir}/gcell/src/lib/spu/libgcell_spu.a"
+       gcell_INCLUDES="-I\${abs_top_srcdir}/gcell/include"
+        gcell_LA="\${abs_top_builddir}/gcell/lib/libgcell.la"
+       gcell_spu_INCLUDES="-I\${abs_top_srcdir}/gcell/include"
+       gcell_spu_LA="\${abs_top_builddir}/gcell/lib/spu/libgcell_spu.a"
        AC_SUBST(gcell_spu_INCLUDES)
        AC_SUBST(gcell_spu_LA)
 
-        dnl kludge up initial swig dependency files
-        AC_CONFIG_COMMANDS([swig_gcell_deps], [
-            touch gr-gcell/src/gcell.d
-        ])
     fi
 
     AC_CONFIG_FILES([ \
         gcell/Makefile \
         gcell/gcell.pc \
-        gcell/src/Makefile \
-        gcell/src/include/Makefile \
-        gcell/src/include/spu/Makefile \
-        gcell/src/lib/Makefile \
-        gcell/src/lib/spu/Makefile \
-        gcell/src/lib/general/Makefile \
-        gcell/src/lib/wrapper/Makefile \
-        gcell/src/lib/runtime/Makefile \
-        gcell/src/apps/Makefile \
-       gcell/src/apps/spu/Makefile \
-       gcell/src/ibm/Makefile \
+        gcell/gcell_spu.pc \
+       gcell/include/Makefile \
+        gcell/include/gcell/Makefile \
+        gcell/include/gcell/spu/Makefile \
+        gcell/lib/Makefile \
+        gcell/lib/spu/Makefile \
+        gcell/lib/general/Makefile \
+        gcell/lib/wrapper/Makefile \
+        gcell/lib/runtime/Makefile \
+        gcell/apps/Makefile \
+       gcell/apps/spu/Makefile \
+       gcell/ibm/Makefile \
     ])
 
     GRC_BUILD_CONDITIONAL(gcell)