Imported Upstream version 3.2.2
[debian/gnuradio] / config / grc_docs.m4
diff --git a/config/grc_docs.m4 b/config/grc_docs.m4
new file mode 100644 (file)
index 0000000..86b31ae
--- /dev/null
@@ -0,0 +1,33 @@
+dnl Copyright 2009 Free Software Foundation, Inc.
+dnl 
+dnl This file is part of GNU Radio
+dnl 
+dnl GNU Radio is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 3, or (at your option)
+dnl any later version.
+dnl 
+dnl GNU Radio is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+dnl GNU General Public License for more details.
+dnl 
+dnl You should have received a copy of the GNU General Public License
+dnl along with GNU Radio; see the file COPYING.  If not, write to
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
+
+AC_DEFUN([GRC_DOCS],[
+    GRC_ENABLE(docs)
+
+    AC_CONFIG_FILES([ \
+       docs/Makefile \
+        docs/doxygen/Doxyfile \
+        docs/doxygen/Makefile \
+        docs/doxygen/other/Makefile \
+        docs/doxygen/xml-swig/Makefile \
+    ])
+
+    GRC_BUILD_CONDITIONAL(docs)
+
+])