Imported Upstream version 2.6.0
[debian/amanda] / config / amanda / i18n.m4
diff --git a/config/amanda/i18n.m4 b/config/amanda/i18n.m4
new file mode 100644 (file)
index 0000000..fc55d70
--- /dev/null
@@ -0,0 +1,26 @@
+# SYNOPSIS
+#
+#   AMANDA_SETUP_I18N
+#
+# OVERVIEW
+#
+#   Set up Amanda's internationalization support.  Note that configure.in
+#   itself must contain (not indented):
+#
+#   AM_GNU_GETTEXT_VERSION([0.15])
+#   AM_GNU_GETTEXT([external])
+#
+AC_DEFUN([AMANDA_SETUP_I18N], [
+    # FreeBSD needs to link libxpg4
+    AC_CHECK_LIB(xpg4, setlocale)
+
+    # ------------------------------------------------------------------
+    # All list of languages for which a translation exist. Each
+    #  language is separated by a space.
+    # ------------------------------------------------------------------
+    ALL_LINGUAS=""
+
+    AC_REQUIRE([AMANDA_INIT_PROGS])
+    AC_PATH_PROG(MSGFMT, msgfmt,,$LOCSYSPATH)
+    AC_PATH_PROG(GETTEXT,gettext,,$LOCSYSPATH)
+])