lintian doesn't like orphan packages with uploaders...
[debian/amanda] / common-src / Makefile.am
index e51fde5be22b2bcbd8b5caeee05b4123e3085d7a..40e2eb63c288ad2aed4b047a945e4d21270eefa2 100644 (file)
@@ -5,20 +5,24 @@ include $(top_srcdir)/config/automake/scripts.am
 include $(top_srcdir)/config/automake/installperms.am
 include $(top_srcdir)/config/automake/precompile.am
 
-INCLUDES =      -I$(top_srcdir)/gnulib   
+INCLUDES =      -I$(top_srcdir)/gnulib
 
 AM_CFLAGS = $(AMANDA_WARNING_CFLAGS)
-AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
+AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS) $(AS_NEEDED_FLAGS)
 
 amlib_LTLIBRARIES =    libamanda.la
 
+sbin_PROGRAMS = amservice
+
 LINT=$(AMLINT)
 LINTFLAGS=$(AMLINTFLAGS)
 
 libamanda_la_SOURCES =         \
        alloc.c                 \
+       am_sl.c                 \
        amfeatures.c            \
        amflock.c               \
+       ipc-binary.c            \
        amxml.c                 \
        clock.c                 \
        columnar.c              \
@@ -33,21 +37,24 @@ libamanda_la_SOURCES =              \
        packet.c                \
        pipespawn.c             \
        protocol.c              \
-       queueing.c              \
-       semaphore.c             \
+       amsemaphore.c           \
        security.c              \
        security-util.c         \
        simpleprng.c            \
-       sl.c                    \
        sockaddr-util.c         \
        stream.c                \
        tapelist.c              \
        timestamp.c             \
-       util.c                  \
-       versuff.c
+       util.c
 # version.c is generated; see below
 nodist_libamanda_la_SOURCES = version.c
 
+INSTALLPERMS_exec = \
+       dest=$(sbindir) chown=root:setuid chmod=04750 \
+               amservice
+
+LDADD = libamanda.la
+
 libamanda_la_LIBADD =          \
        ../gnulib/libgnu.la
 
@@ -83,24 +90,23 @@ endif
 if WANT_BSDUDP_SECURITY
 libamanda_la_SOURCES += bsdudp-security.c
 endif
-if WANT_KRB4_SECURITY
-libamanda_la_SOURCES += krb4-security.c        
-endif
 if WANT_KRB5_SECURITY
 libamanda_la_SOURCES += krb5-security.c
 endif
 
 libamanda_la_SOURCES += local-security.c
 
-libamanda_la_LDFLAGS =  -release $(VERSION)
+libamanda_la_LDFLAGS =  -release $(VERSION) $(AS_NEEDED_FLAGS)
 
 noinst_HEADERS =               \
        amanda.h                \
        amfeatures.h            \
+       ipc-binary.h            \
        amxml.h                 \
        arglist.h               \
        clock.h                 \
        columnar.h              \
+       directtcp.h             \
        amflock.h               \
        conffile.h              \
        debug.h                 \
@@ -109,16 +115,15 @@ noinst_HEADERS =          \
        file.h                  \
        fileheader.h            \
        glib-util.h             \
+       match.h                 \
        packet.h                \
        pipespawn.h             \
        protocol.h              \
-       queue.h                 \
-       queueing.h              \
-       semaphore.h             \
+       amsemaphore.h           \
        security.h              \
        security-util.h         \
        simpleprng.h            \
-       sl.h                    \
+       am_sl.h                 \
        sockaddr-util.h         \
        stream.h                \
        tapelist.h              \
@@ -139,7 +144,6 @@ EXTRA_PROGRAMS = genversion $(TEST_PROGS)
 
 genversion_SOURCES = genversion.c svn-info.h
 genversion_LDADD = $(libamanda_la_LIBADD)      \
-       versuff.lo                              \
        ../gnulib/libgnu.la
 
 genversion.h: $(top_builddir)/config.status
@@ -156,7 +160,7 @@ version.c: genversion$(EXEEXT)
 BUILT_SOURCES += genversion.h version.c
 
 # these are used for testing only:
-TEST_PROGS = file bsdsecurity amfeatures
+TEST_PROGS = file bsdsecurity
 
 CLEANFILES += *.test.c
 DISTCLEANFILES += version.c genversion genversion.h
@@ -166,10 +170,14 @@ DISTCLEANFILES += version.c genversion genversion.h
 STANDARD_COMMON_STUFF_NOT_FILE = \
        alloc.lo \
        clock.lo \
+       conffile.lo \
        debug.lo \
+       glib-util.lo \
        util.lo \
        match.lo \
-       sl.lo
+       sl.lo \
+       sockaddr-util.lo \
+       timestamp.lo
 
 STANDARD_COMMON_STUFF = \
        $(STANDARD_COMMON_STUFF_NOT_FILE) \
@@ -188,11 +196,7 @@ bsdsecurity_LDADD = $(libamanda_a_LIBADD) \
                    file.lo \
                    packet.lo \
                    security.lo \
-                   ssh-security.lo \
-                   versuff.lo
-
-amfeatures_SOURCES = amfeatures.test.c
-amfeatures_LDADD = $(libamanda_la_LIBADD) $(STANDARD_COMMON_STUFF)
+                   ssh-security.lo
 
 # libtestutils.la
 #
@@ -207,7 +211,8 @@ libtestutils_la_SOURCES = \
 
 # automake-style tests
 
-TESTS = amflock-test event-test semaphore-test queueing-test quoting-test
+TESTS = amflock-test event-test amsemaphore-test quoting-test \
+       ipc-binary-test hexencode-test fileheader-test match-test
 noinst_PROGRAMS = $(TESTS)
 
 amflock_test_SOURCES = amflock-test.c
@@ -216,30 +221,33 @@ amflock_test_LDADD = libamanda.la libtestutils.la
 event_test_SOURCES = event-test.c
 event_test_LDADD = libamanda.la libtestutils.la
 
-semaphore_test_SOURCES = semaphore-test.c
-semaphore_test_LDADD = libamanda.la libtestutils.la
-
-queueing_test_SOURCES = queueing-test.c
-queueing_test_LDADD = libamanda.la libtestutils.la
+amsemaphore_test_SOURCES = amsemaphore-test.c
+amsemaphore_test_LDADD = libamanda.la libtestutils.la
 
 quoting_test_SOURCES = quoting-test.c
 quoting_test_LDADD = libamanda.la libtestutils.la
 
+ipc_binary_test_SOURCES = ipc-binary-test.c
+ipc_binary_test_LDADD = libamanda.la libtestutils.la
+
+hexencode_test_SOURCES = hexencode-test.c
+hexencode_test_LDADD = libamanda.la libtestutils.la
+
+fileheader_test_SOURCES = fileheader-test.c
+fileheader_test_LDADD = libamanda.la libtestutils.la
+
+match_test_SOURCES = match-test.c
+match_test_LDADD = libamanda.la libtestutils.la
+
 # scripts
 
-# divide scripts up both by language, by destination directory, and by whether they
-# should get checked (stuff in *_SCRIPTS_* isn't syntax checked; this is necessary
-# for perl scripts that use Amanda::* packages)
-sbin_CHECK_PERL = \
+# divide scripts up both by language and destination directory
+sbin_SCRIPTS_PERL = \
            amgpgcrypt \
            amcryptsimple \
            amgetconf
-sbin_SCRIPTS_PERL = \
-           $(sbin_CHECK_PERL)
 
-amlibexec_CHECK_PERL =
-amlibexec_SCRIPTS_PERL = \
-           $(amlibexec_CHECK_PERL)
+amlibexec_SCRIPTS_PERL =
 
 sbin_SCRIPTS_SHELL = \
            amcrypt \
@@ -254,7 +262,6 @@ SCRIPTS_INCLUDE = \
 
 EXTRA_DIST += amanda-sh-lib.sh.in
 
-CHECK_PERL = $(sbin_CHECK_PERL) $(amlibexec_CHECK_PERL)
 SCRIPTS_PERL = $(sbin_SCRIPTS_PERL) $(amlibexec_SCRIPTS_PERL)
 SCRIPTS_SHELL = $(sbin_SCRIPTS_SHELL) $(amlibexec_SCRIPTS_SHELL)
 
@@ -264,9 +271,6 @@ sbin_SCRIPTS = $(sbin_SCRIPTS_PERL) $(sbin_SCRIPTS_SHELL)
 
 # installation
 
-INSTALLPERMS_data = dest=$(sbindir) chown=amanda $(sbin_SCRIPTS) \
-                   dest=$(amlibexecdir) chown=amanda $(amlibexec_SCRIPTS) $(amlibexec_DATA)
-
 lint:
        @echo $(LINT) $(libamanda_la_SOURCES)
        @$(LINT) $(LINTFLAGS) $(CPPFLAGS) $(DEFS) -I. -I$(top_builddir)/config $(INCLUDES) $(libamanda_la_SOURCES)