patches from Simon Ruderich that broaden use of hardening build flags
[debian/sudo] / common / Makefile.in
index a1319eff6304842f8b3884511636c7ce8a5e9f88..9ee10c7f2968714300f6d1d0f1b74fb11b29d9d4 100644 (file)
@@ -35,6 +35,9 @@ CPPFLAGS = -I$(incdir) -I$(top_builddir) -I$(top_srcdir) @CPPFLAGS@
 # Usually -O and/or -g
 CFLAGS = @CFLAGS@
 
+# Linker flags
+LDFLAGS = @LDFLAGS@
+
 # OS dependent defines
 DEFS = @OSDEFS@
 
@@ -56,7 +59,7 @@ Makefile: $(srcdir)/Makefile.in
        $(LIBTOOL) --mode=compile $(CC) -c -o $@ $(CPPFLAGS) $(CFLAGS) $(DEFS) $<
 
 libcommon.la: $(LTOBJS)
-       $(LIBTOOL) --mode=link $(CC) -o $@ $(LTOBJS) -no-install
+       $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(LTOBJS) -no-install
 
 pre-install: