maint: merge build improvements from coreutils
[debian/gzip] / cfg.mk
diff --git a/cfg.mk b/cfg.mk
index 7ce32740f9d5c5a3f803d82650bf7667eef37049..ff35396fa4b35118803fb44376bd195c8a09449c 100644 (file)
--- a/cfg.mk
+++ b/cfg.mk
@@ -1,5 +1,5 @@
 # Customize maint.mk                           -*- makefile -*-
-# Copyright (C) 2003-2010 Free Software Foundation, Inc.
+# Copyright (C) 2003-2012 Free Software Foundation, Inc.
 
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -19,6 +19,7 @@ manual_title = gzip: the data compression program
 
 # Tests not to run as part of "make distcheck".
 local-checks-to-skip =         \
+  sc_bindtextdomain            \
   sc_error_message_period      \
   sc_error_message_uppercase   \
   sc_m4_quote_check            \
@@ -28,6 +29,7 @@ local-checks-to-skip =                \
   sc_prohibit_atoi_atof                \
   sc_prohibit_stat_st_blocks   \
   sc_space_tab                 \
+  sc_texinfo_acronym           \
   sc_useless_cpp_parens
 
 
@@ -37,15 +39,47 @@ bootstrap-tools = autoconf,automake,gnulib
 # Now that we have better tests, make this the default.
 export VERBOSE = yes
 
-old_NEWS_hash = 22b19691660f1870cec5f64b2c0e4641
+old_NEWS_hash = cfb389be1b246e15a87a2272ad3736d7
 
 sc_obs_header_regex = \
   \<(STDC_HEADERS|HAVE_(LIMITS|STRING|UNISTD|STDLIB)_H)\>
 sc_prohibit_obsolete_HAVE_HEADER_H:
-       @re='^[  ]*#[    ]*(el)?if.*$(sc_obs_header_regex)' \
-       msg='remove the above obsolete #if...HAVE_HEADER_H test(s)' \
-         $(_prohibit_regexp)
+       @prohibit='^[    ]*#[    ]*(el)?if.*$(sc_obs_header_regex)' \
+       halt='remove the above obsolete #if...HAVE_HEADER_H test(s)' \
+         $(_sc_search_regexp)
 
 update-copyright-env = \
   UPDATE_COPYRIGHT_USE_INTERVALS=1 \
   UPDATE_COPYRIGHT_MAX_LINE_LENGTH=79
+
+# Indent only with spaces.
+sc_prohibit_tab_based_indentation:
+       @prohibit='^ *  '                                               \
+       halt='TAB in indentation; use only spaces'                      \
+         $(_sc_search_regexp)
+
+# Don't use "indent-tabs-mode: nil" anymore.  No longer needed.
+sc_prohibit_emacs__indent_tabs_mode__setting:
+       @prohibit='^( *[*#] *)?indent-tabs-mode:'                       \
+       halt='use of emacs indent-tabs-mode: setting'                   \
+         $(_sc_search_regexp)
+
+include $(srcdir)/dist-check.mk
+
+exclude_file_name_regexp--sc_file_system = ^NEWS$$
+exclude_file_name_regexp--sc_prohibit_tab_based_indentation = \
+  (^|/)(GNU)?[Mm]akefile|(^|/)ChangeLog|\.(am|mk)$$
+exclude_file_name_regexp--sc_require_config_h = ^lib/match\.c$$
+exclude_file_name_regexp--sc_require_config_h_first = ^lib/match\.c$$
+exclude_file_name_regexp--sc_prohibit_empty_lines_at_EOF = \
+  ^tests/hufts-segv\.gz$$
+exclude_file_name_regexp--sc_prohibit_strcmp = ^gzip\.c$$
+exclude_file_name_regexp--sc_prohibit_always-defined_macros = ^tailor\.h$$
+
+# Tell the tight_scope rule that sources are in ".".
+export _gl_TS_dir = .
+
+# Tell the tight_scope rule that these variables are deliberately "extern".
+export _gl_TS_unmarked_extern_vars = \
+  block_start d_buf inbuf outbuf prev read_buf strstart window \
+  match_start prev_length max_chain_length good_match