maint: update copyright year ranges to include 2015; update gnulib
[debian/gzip] / cfg.mk
diff --git a/cfg.mk b/cfg.mk
index 0209d6365f532b56021bffdf12e94734046c8ed2..f39c6fe31ad702acfd33be26f98105ea510e7ed4 100644 (file)
--- a/cfg.mk
+++ b/cfg.mk
@@ -1,5 +1,5 @@
 # Customize maint.mk                           -*- makefile -*-
-# Copyright (C) 2003-2011 Free Software Foundation, Inc.
+# Copyright (C) 2003-2015 Free Software Foundation, Inc.
 
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -22,16 +22,8 @@ local-checks-to-skip =               \
   sc_bindtextdomain            \
   sc_error_message_period      \
   sc_error_message_uppercase   \
-  sc_m4_quote_check            \
-  sc_obsolete_symbols          \
   sc_program_name              \
-  sc_prohibit_S_IS_definition  \
-  sc_prohibit_atoi_atof                \
-  sc_prohibit_stat_st_blocks   \
-  sc_space_tab                 \
-  sc_texinfo_acronym           \
-  sc_useless_cpp_parens
-
+  sc_texinfo_acronym
 
 # Tools used to bootstrap this package, used for "announcement".
 bootstrap-tools = autoconf,automake,gnulib
@@ -39,7 +31,7 @@ bootstrap-tools = autoconf,automake,gnulib
 # Now that we have better tests, make this the default.
 export VERBOSE = yes
 
-old_NEWS_hash = 4e76bc5d3e489bb63342e85762172502
+old_NEWS_hash = dada3abad00e555713d6e99738224904
 
 sc_obs_header_regex = \
   \<(STDC_HEADERS|HAVE_(LIMITS|STRING|UNISTD|STDLIB)_H)\>
@@ -74,6 +66,12 @@ exclude_file_name_regexp--sc_require_config_h_first = ^lib/match\.c$$
 exclude_file_name_regexp--sc_prohibit_empty_lines_at_EOF = \
   ^tests/hufts-segv\.gz$$
 exclude_file_name_regexp--sc_prohibit_strcmp = ^gzip\.c$$
+exclude_file_name_regexp--sc_prohibit_always-defined_macros = ^tailor\.h$$
+exclude_file_name_regexp--sc_prohibit_atoi_atof = ^(gzip|sample/sub)\.c$$
+exclude_file_name_regexp--sc_space_tab = ^lib/match\.c$$
+exclude_file_name_regexp--sc_useless_cpp_parens = ^(lib/match\.c|tailor\.h)$$
+
+exclude_file_name_regexp--sc_prohibit_double_semicolon = ^lib/match\.c$$
 
 # Tell the tight_scope rule that sources are in ".".
 export _gl_TS_dir = .
@@ -81,4 +79,4 @@ export _gl_TS_dir = .
 # Tell the tight_scope rule that these variables are deliberately "extern".
 export _gl_TS_unmarked_extern_vars = \
   block_start d_buf inbuf outbuf prev read_buf strstart window \
-  match_start prev_length max_chain_length good_match
+  match_start prev_length max_chain_length good_match nice_match