zgrep: don't assume traditional behavior with signal numbers
[debian/gzip] / cfg.mk
diff --git a/cfg.mk b/cfg.mk
index 88b0d82bcb3c19d65b985b0297ce51a22bebe7e3..879637b787f1c8ef91e658bd2512f3063234674a 100644 (file)
--- a/cfg.mk
+++ b/cfg.mk
@@ -28,6 +28,7 @@ local-checks-to-skip =                \
   sc_prohibit_atoi_atof                \
   sc_prohibit_stat_st_blocks   \
   sc_space_tab                 \
+  sc_texinfo_acronym           \
   sc_useless_cpp_parens
 
 
@@ -37,11 +38,29 @@ bootstrap-tools = autoconf,automake,gnulib
 # Now that we have better tests, make this the default.
 export VERBOSE = yes
 
-old_NEWS_hash = 22b19691660f1870cec5f64b2c0e4641
+old_NEWS_hash = e35901d8427a032d2b88a3195ed24a8f
 
 sc_obs_header_regex = \
   \<(STDC_HEADERS|HAVE_(LIMITS|STRING|UNISTD|STDLIB)_H)\>
 sc_prohibit_obsolete_HAVE_HEADER_H:
-       @re='^[  ]*#[    ]*(el)?if.*$(sc_obs_header_regex)' \
-       msg='remove the above obsolete #if...HAVE_HEADER_H test(s)' \
-         $(_prohibit_regexp)
+       @prohibit='^[    ]*#[    ]*(el)?if.*$(sc_obs_header_regex)' \
+       halt='remove the above obsolete #if...HAVE_HEADER_H test(s)' \
+         $(_sc_search_regexp)
+
+update-copyright-env = \
+  UPDATE_COPYRIGHT_USE_INTERVALS=1 \
+  UPDATE_COPYRIGHT_MAX_LINE_LENGTH=79
+
+# Indent only with spaces.
+sc_prohibit_tab_based_indentation:
+       @prohibit='^ *  '                                               \
+       halt='TAB in indentation; use only spaces'                      \
+         $(_sc_search_regexp)
+
+# Don't use "indent-tabs-mode: nil" anymore.  No longer needed.
+sc_prohibit_emacs__indent_tabs_mode__setting:
+       @prohibit='^( *[*#] *)?indent-tabs-mode:'                       \
+       halt='use of emacs indent-tabs-mode: setting'                   \
+         $(_sc_search_regexp)
+
+include $(srcdir)/dist-check.mk