maint: adjust to Gnulib, Automake changes
[debian/gzip] / cfg.mk
diff --git a/cfg.mk b/cfg.mk
index cbe5297d3a9effdce699de716b9c18a9990a1688..43668542b0e394e0048d6822912f85f4c79f5124 100644 (file)
--- a/cfg.mk
+++ b/cfg.mk
@@ -1,5 +1,5 @@
 # Customize maint.mk                           -*- makefile -*-
-# Copyright (C) 2003-2011 Free Software Foundation, Inc.
+# Copyright (C) 2003-2013 Free Software Foundation, Inc.
 
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -39,7 +39,7 @@ bootstrap-tools = autoconf,automake,gnulib
 # Now that we have better tests, make this the default.
 export VERBOSE = yes
 
-old_NEWS_hash = 4e76bc5d3e489bb63342e85762172502
+old_NEWS_hash = cfb389be1b246e15a87a2272ad3736d7
 
 sc_obs_header_regex = \
   \<(STDC_HEADERS|HAVE_(LIMITS|STRING|UNISTD|STDLIB)_H)\>
@@ -65,3 +65,21 @@ sc_prohibit_emacs__indent_tabs_mode__setting:
          $(_sc_search_regexp)
 
 include $(srcdir)/dist-check.mk
+
+exclude_file_name_regexp--sc_file_system = ^NEWS$$
+exclude_file_name_regexp--sc_prohibit_tab_based_indentation = \
+  (^|/)(GNU)?[Mm]akefile|(^|/)ChangeLog|\.(am|mk)$$
+exclude_file_name_regexp--sc_require_config_h = ^lib/match\.c$$
+exclude_file_name_regexp--sc_require_config_h_first = ^lib/match\.c$$
+exclude_file_name_regexp--sc_prohibit_empty_lines_at_EOF = \
+  ^tests/hufts-segv\.gz$$
+exclude_file_name_regexp--sc_prohibit_strcmp = ^gzip\.c$$
+exclude_file_name_regexp--sc_prohibit_always-defined_macros = ^tailor\.h$$
+
+# Tell the tight_scope rule that sources are in ".".
+export _gl_TS_dir = .
+
+# Tell the tight_scope rule that these variables are deliberately "extern".
+export _gl_TS_unmarked_extern_vars = \
+  block_start d_buf inbuf outbuf prev read_buf strstart window \
+  match_start prev_length max_chain_length good_match nice_match