doc: bring up to date and fix troff typos
[debian/gzip] / bootstrap.conf
index 5f1e653068961520efea1460574992c83af53da9..e5d14c27a58344e65ddb3abbf6e504373ed6b0d5 100644 (file)
@@ -1,10 +1,10 @@
 # Bootstrap configuration.
 
-# Copyright (C) 2006-2009 Free Software Foundation, Inc.
+# Copyright (C) 2006-2007, 2009-2012 Free Software Foundation, Inc.
 
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
+# the Free Software Foundation; either version 3 of the License, or
 # (at your option) any later version.
 
 # This program is distributed in the hope that it will be useful,
@@ -29,20 +29,27 @@ fclose
 fcntl
 fcntl-safer
 fdl
+fdopendir
 fprintf-posix
 getopt-gnu
 git-version-gen
 gitlog-to-changelog
 gnu-make
 gnu-web-doc-update
-gnupload
 gnumakefile
+gnupload
+ignore-value
+largefile
+lib-ignore
 lstat
 maintainer-makefile
-malloc
+malloc-gnu
+manywarnings
 perror
 printf-posix
-realloc
+readme-release
+realloc-gnu
+savedir
 stat-time
 sys_stat
 time
@@ -57,8 +64,11 @@ yesno
 gnulib_tool_option_extras="\
  --avoid getline\
  --avoid rpmatch\
+ --symlink\
+ --makefile-name=gnulib.mk\
 "
 
+
 # Create build-aux, since 'bootstrap' won't do that for us.
 mkdir -p build-aux
 
@@ -75,5 +85,10 @@ rsync      -
 tar        -
 "
 
+bootstrap_epilogue()
+{
+  perl -pi -e "s/\@PACKAGE\@/$package/g" README-release
+}
+
 # Automake requires that ChangeLog exist.
 touch ChangeLog || exit 1