tests: don’t be so strict about timestamps
[debian/gzip] / bootstrap.conf
index 5f1e653068961520efea1460574992c83af53da9..e44837faeba848f443fe2d416f185154f31860a2 100644 (file)
@@ -1,10 +1,10 @@
 # Bootstrap configuration.
 
-# Copyright (C) 2006-2009 Free Software Foundation, Inc.
+# Copyright (C) 2006-2007, 2009-2017 Free Software Foundation, Inc.
 
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
+# the Free Software Foundation; either version 3 of the License, or
 # (at your option) any later version.
 
 # This program is distributed in the hope that it will be useful,
 # GNU General Public License for more details.
 
 # You should have received a copy of the GNU General Public License
-# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+# along with this program.  If not, see <https://www.gnu.org/licenses/>.
 
 
-# gzip doesn't use gettext.
-IMPORT_FROM_GETTEXT=no
-
 # gnulib modules used by this package.
 gnulib_modules='
 announce-gen
 calloc
 close
-closein
+dirname-lgpl
+dosname
 fclose
 fcntl
 fcntl-safer
 fdl
+fdatasync
+fdopendir
 fprintf-posix
+fsync
 getopt-gnu
 git-version-gen
 gitlog-to-changelog
 gnu-make
 gnu-web-doc-update
-gnupload
 gnumakefile
+gnupload
+ignore-value
+intprops
+largefile
+lib-ignore
 lstat
 maintainer-makefile
-malloc
+malloc-gnu
+manywarnings
+openat-safer
 perror
 printf-posix
-realloc
+readme-release
+realloc-gnu
+savedir
 stat-time
+stdnoreturn
 sys_stat
 time
+unistd-safer
+unlinkat
 update-copyright
 utimens
+verify
 xalloc
+year2038
 yesno
 '
 
@@ -57,8 +71,11 @@ yesno
 gnulib_tool_option_extras="\
  --avoid getline\
  --avoid rpmatch\
+ --symlink\
+ --makefile-name=gnulib.mk\
 "
 
+
 # Create build-aux, since 'bootstrap' won't do that for us.
 mkdir -p build-aux
 
@@ -75,5 +92,10 @@ rsync      -
 tar        -
 "
 
+bootstrap_epilogue()
+{
+  perl -pi -e "s/\@PACKAGE\@/$package/g" README-release
+}
+
 # Automake requires that ChangeLog exist.
 touch ChangeLog || exit 1