version 1.6
[debian/gzip] / bootstrap.conf
index 7229807e625b077392395ca6fd143c294643b1c0..3fffd7f37c1adf282562af0426ad69d2dc3b61f3 100644 (file)
@@ -1,11 +1,11 @@
 # Bootstrap configuration.
 
-# Copyright (C) 2006 Free Software Foundation, Inc.
+# Copyright (C) 2006-2007, 2009-2013 Free Software Foundation, Inc.
 
-# This program is free software; you can redistribute it and/or modify
+# This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
-# any later version.
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
 
 # This program is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -13,9 +13,7 @@
 # GNU General Public License for more details.
 
 # You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
-# 02110-1301, USA.
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
 
 # gzip doesn't use gettext.
@@ -23,15 +21,42 @@ IMPORT_FROM_GETTEXT=no
 
 # gnulib modules used by this package.
 gnulib_modules='
-       fcntl
-       fcntl-safer
-       fdl
-       getopt
-       stat-time
-       sys_stat
-       utimens
-       xalloc
-       yesno
+announce-gen
+calloc
+close
+closein
+fclose
+fcntl
+fcntl-safer
+fdl
+fdopendir
+fprintf-posix
+getopt-gnu
+git-version-gen
+gitlog-to-changelog
+gnu-make
+gnu-web-doc-update
+gnumakefile
+gnupload
+ignore-value
+largefile
+lib-ignore
+lstat
+maintainer-makefile
+malloc-gnu
+manywarnings
+perror
+printf-posix
+readme-release
+realloc-gnu
+savedir
+stat-time
+sys_stat
+time
+update-copyright
+utimens
+xalloc
+yesno
 '
 
 # Additional gnulib-tool options to use.  Use "\newline" to break lines.
@@ -39,7 +64,31 @@ gnulib_modules='
 gnulib_tool_option_extras="\
  --avoid getline\
  --avoid rpmatch\
+ --symlink\
+ --makefile-name=gnulib.mk\
 "
 
+
 # Create build-aux, since 'bootstrap' won't do that for us.
 mkdir -p build-aux
+
+# Build prerequisites
+buildreq="\
+autoconf   2.61
+automake   1.11
+autopoint  -
+gettext    -
+git        1.4.4
+makeinfo   -
+perl       5.5
+rsync      -
+tar        -
+"
+
+bootstrap_epilogue()
+{
+  perl -pi -e "s/\@PACKAGE\@/$package/g" README-release
+}
+
+# Automake requires that ChangeLog exist.
+touch ChangeLog || exit 1