zgrep: exit with status 0 if a file matches and there's no trouble
[debian/gzip] / bootstrap.conf
index 3ab328a78c245a8997282973708ae84ce2ae1b8c..306b77380d559328aef9ae76f57b04fba57ac48f 100644 (file)
@@ -1,10 +1,10 @@
 # Bootstrap configuration.
 
-# Copyright (C) 2006-2009 Free Software Foundation, Inc.
+# Copyright (C) 2006-2007, 2009-2014 Free Software Foundation, Inc.
 
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
+# the Free Software Foundation; either version 3 of the License, or
 # (at your option) any later version.
 
 # This program is distributed in the hope that it will be useful,
@@ -21,22 +21,42 @@ IMPORT_FROM_GETTEXT=no
 
 # gnulib modules used by this package.
 gnulib_modules='
-       closein
-       fcntl
-       fcntl-safer
-       fdl
-       getopt-gnu
-       git-version-gen
-       gitlog-to-changelog
-       gnu-make
-       gnumakefile
-       maintainer-makefile
-       stat-time
-       sys_stat
-       time
-       utimens
-       xalloc
-       yesno
+announce-gen
+calloc
+close
+closein
+fclose
+fcntl
+fcntl-safer
+fdl
+fdopendir
+fprintf-posix
+getopt-gnu
+git-version-gen
+gitlog-to-changelog
+gnu-make
+gnu-web-doc-update
+gnumakefile
+gnupload
+ignore-value
+largefile
+lib-ignore
+lstat
+maintainer-makefile
+malloc-gnu
+manywarnings
+perror
+printf-posix
+readme-release
+realloc-gnu
+savedir
+stat-time
+sys_stat
+time
+update-copyright
+utimens
+xalloc
+yesno
 '
 
 # Additional gnulib-tool options to use.  Use "\newline" to break lines.
@@ -44,8 +64,11 @@ gnulib_modules='
 gnulib_tool_option_extras="\
  --avoid getline\
  --avoid rpmatch\
+ --symlink\
+ --makefile-name=gnulib.mk\
 "
 
+
 # Create build-aux, since 'bootstrap' won't do that for us.
 mkdir -p build-aux
 
@@ -62,5 +85,10 @@ rsync      -
 tar        -
 "
 
+bootstrap_epilogue()
+{
+  perl -pi -e "s/\@PACKAGE\@/$package/g" README-release
+}
+
 # Automake requires that ChangeLog exist.
 touch ChangeLog || exit 1