Port to Oracle Solaris Studio 12.4
[debian/gzip] / bootstrap.conf
index f0afe13bbf1f12ab6eae917b42239e735de8b8bd..25acaacc87ff7c87458cc1758ab15e82a03af4a8 100644 (file)
@@ -1,10 +1,10 @@
 # Bootstrap configuration.
 
-# Copyright (C) 2006-2009 Free Software Foundation, Inc.
+# Copyright (C) 2006-2007, 2009-2016 Free Software Foundation, Inc.
 
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
+# the Free Software Foundation; either version 3 of the License, or
 # (at your option) any later version.
 
 # This program is distributed in the hope that it will be useful,
@@ -25,12 +25,15 @@ announce-gen
 calloc
 close
 closein
+dirname-lgpl
 fclose
 fcntl
 fcntl-safer
 fdl
+fdatasync
 fdopendir
 fprintf-posix
+fsync
 getopt-gnu
 git-version-gen
 gitlog-to-changelog
@@ -38,18 +41,28 @@ gnu-make
 gnu-web-doc-update
 gnumakefile
 gnupload
+ignore-value
+intprops
+largefile
+lib-ignore
 lstat
 maintainer-makefile
-malloc
+malloc-gnu
 manywarnings
+openat-safer
 perror
 printf-posix
-realloc
+readme-release
+realloc-gnu
+savedir
 stat-time
 sys_stat
 time
+unistd-safer
+unlinkat
 update-copyright
 utimens
+verify
 xalloc
 yesno
 '
@@ -59,8 +72,11 @@ yesno
 gnulib_tool_option_extras="\
  --avoid getline\
  --avoid rpmatch\
+ --symlink\
+ --makefile-name=gnulib.mk\
 "
 
+
 # Create build-aux, since 'bootstrap' won't do that for us.
 mkdir -p build-aux
 
@@ -77,5 +93,10 @@ rsync      -
 tar        -
 "
 
+bootstrap_epilogue()
+{
+  perl -pi -e "s/\@PACKAGE\@/$package/g" README-release
+}
+
 # Automake requires that ChangeLog exist.
 touch ChangeLog || exit 1