add build dep on libcurl4-openssl-dev needed by Amazon S3 driver
[debian/amanda] / amandad-src / Makefile.am
index f62a51e0f32624e02845801f794581396967f3ed..4c86e4b50e23e2b94a4078c503630a045a3c7589 100644 (file)
@@ -1,5 +1,6 @@
 # Makefile for Amanda client programs.
 
+include $(top_srcdir)/config/automake/vars.am
 include $(top_srcdir)/config/automake/installperms.am
 include $(top_srcdir)/config/automake/precompile.am
 
@@ -10,11 +11,10 @@ INCLUDES =  -I$(top_builddir)/common-src \
 AM_CFLAGS = $(AMANDA_WARNING_CFLAGS)
 AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
 
-LINT=@AMLINT@
-LINTFLAGS=@AMLINTFLAGS@
+LINT=$(AMLINT)
+LINTFLAGS=$(AMLINTFLAGS)
 
 amlib_LTLIBRARIES =       libamandad.la
-LIB_EXTENSION = la
 
 amlibexec_PROGRAMS =   amandad
 
@@ -31,21 +31,14 @@ noinst_HEADERS  = amandad.h
 # routines, and second to pick up any references in the other libraries.
 ###
 
-LDADD = ../common-src/libamanda.$(LIB_EXTENSION) \
-       libamandad.$(LIB_EXTENSION) \
-       ../common-src/libamanda.$(LIB_EXTENSION) \
-       ../gnulib/libgnu.$(LIB_EXTENSION)
-
-INSTALLPERMS_exec = \
-       dest=$(amlibexecdir) chown=amanda \
-               $(amlibexec_PROGRAMS)
-
-INSTALLPERMS_data = \
-       dest=$(amlibexecdir) chown=amanda \
-               $(amlibexec_SCRIPTS)
+LDADD = ../common-src/libamanda.la \
+       libamandad.la \
+       ../common-src/libamanda.la \
+       ../gnulib/libgnu.la
 
 lint:
        @ for p in $(amlibexec_PROGRAMS); do                                    \
+               p=`basename $$p $(EXEEXT)`;                                     \
                f="$$p.c $(libamandad_la_SOURCES)";                             \
                (cd ../common-src; make listlibsrc);                            \
                f="$$f "`cat ../common-src/listlibsrc.output`;                  \