prepare to upload
[debian/sudo] / Makefile.in
index d367fd25d903b6305ee03eaac68e9460a7e73aa0..1fbed4cd05b14762342247ca399ae6079ea2cb35 100644 (file)
@@ -47,7 +47,7 @@ sudoers_mode = @SUDOERS_MODE@
 
 SUBDIRS = compat common @ZLIB_SRC@ plugins/sudoers src include doc
 
-SAMPLES = plugins/sample plugins/sample_group
+SAMPLES = plugins/sample plugins/sample_group plugins/system_group
 
 VERSION = @PACKAGE_VERSION@
 PACKAGE_TARNAME = @PACKAGE_TARNAME@
@@ -67,7 +67,7 @@ POTFILES = src/po/sudo.pot plugins/sudoers/po/sudoers.pot
 MSGFMT = msgfmt
 MSGMERGE = msgmerge
 XGETTEXT = xgettext
-XGETTEXT_OPTS = -k_ -kN_ --copyright-holder="Todd C. Miller" \
+XGETTEXT_OPTS = -F -k_ -kN_ --copyright-holder="Todd C. Miller" \
                "--msgid-bugs-address=http://www.sudo.ws/bugs" \
                --package-name=@PACKAGE_NAME@ --package-version=$(VERSION) \
                --flag warning:1:c-format --flag warningx:1:c-format \
@@ -114,11 +114,7 @@ uninstall: uninstall-nls
 uninstall-nls:
        for pot in $(POTFILES); do \
            domain=`basename $$pot .pot`; \
-           podir=`dirname $$pot`; \
-           for po in $$podir/*.po; do \
-               lang=`basename $$po .po`; \
-               rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$$domain.mo; \
-           done; \
+           rm -f $(DESTDIR)$(localedir)/*/LC_MESSAGES/$$domain.mo; \
        done
 
 autoconf:
@@ -136,18 +132,19 @@ depend: siglist.c
            $(srcdir)/compat/Makefile.in $(srcdir)/plugins/sample/Makefile.in \
            $(srcdir)/plugins/sample_group/Makefile.in \
            $(srcdir)/plugins/sudoers/Makefile.in \
+           $(srcdir)/plugins/system_group/Makefile.in \
            $(srcdir)/src/Makefile.in $(srcdir)/zlib/Makefile.in; \
        ./config.status --file $(srcdir)/common/Makefile \
            --file $(srcdir)/compat/Makefile \
            --file $(srcdir)/plugins/sample/Makefile \
            --file $(srcdir)/plugins/sample_group/Makefile \
            --file $(srcdir)/plugins/sudoers/Makefile \
+           --file $(srcdir)/plugins/system_group/Makefile \
            --file $(srcdir)/src/Makefile --file $(srcdir)/zlib/Makefile
 
-# The 1.8 branch started February 25, 2011
 ChangeLog:
        if test -d $(srcdir)/.hg && cd $(srcdir); then \
-           if hg log --style=changelog -b 1.8 > $@.tmp && hg log --style=changelog -b default --date '<2011-02-25 21:30:00' >> $@.tmp; then \
+           if hg log --style=changelog -b default > $@.tmp; then \
                mv -f $@.tmp $@; \
            else \
                rm -f $@.tmp; \
@@ -166,7 +163,9 @@ libtool: $(LIBTOOL_DEPS)
 Makefile: $(srcdir)/Makefile.in
        ./config.status --file Makefile
 
-sync-po:
+sync-po: rsync-po compile-po
+
+rsync-po:
        rsync -Lrtvz  translationproject.org::tp/latest/sudo/ src/po/
        rsync -Lrtvz  translationproject.org::tp/latest/sudoers/ plugins/sudoers/po/
 
@@ -182,7 +181,7 @@ update-pot:
                    *) echo unknown domain $$domain; continue;; \
                esac; \
                $(XGETTEXT) $(XGETTEXT_OPTS) -d$$domain $$cfiles -o $$pot.tmp; \
-               if diff -I'^.POT-Creation-Date' $$pot.tmp $$pot >/dev/null; then \
+               if diff -I'^.POT-Creation-Date' -I'^.Project-Id-Version' -I'^#' $$pot.tmp $$pot >/dev/null; then \
                    rm -f $$pot.tmp; \
                else \
                    mv -f $$pot.tmp $$pot; \
@@ -231,12 +230,13 @@ install-nls:
            for pot in $(POTFILES); do \
                podir=`dirname $$pot`; \
                domain=`basename $$pot .pot`; \
+               SUDO_LINGUAS=$${LINGUAS-"`echo $$podir/*.mo|sed 's:'$$podir'/\([^ ]*\).mo:\1:g'`"}; \
                echo $(ECHO_N) "Installing $$domain message catalogs:$(ECHO_C)"; \
-               for mo in $$podir/*.mo; do \
-                   lang=`basename $$mo .mo`; \
+               for lang in $$SUDO_LINGUAS; do \
+                   test -s $$podir/$$lang.mo || continue; \
                    echo $(ECHO_N) " $$lang$(ECHO_C)"; \
                    $(SHELL) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES; \
-                   $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0644 $$mo $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$$domain.mo; \
+                   $(INSTALL) -O $(install_uid) -G $(install_gid) -m 0444 $$podir/$$lang.mo $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$$domain.mo; \
                done; \
                echo ""; \
            done; \