Fixed ticket 10. Merged from /gnuradio/developers/branches/jcorgan/ticket-10.
[debian/gnuradio] / Makefile.common
index 2259cac0aba7e7bfde7b2167ff682ff6da8f5c1d..f0f02119abd5227b9662b6feeb59a1497f83735b 100644 (file)
@@ -36,5 +36,33 @@ grpyexecdir = $(pyexecdir)/gnuradio
 # swig flags
 SWIGPYTHONFLAGS = -fvirtual -python -modern
 
-# gnuradio-core library link command
-GNURADIO_CORE_LIBS = -L$(top_srcdir)/gnuradio-core/src/lib/.libs -lgnuradio-core -lfftw3f -lm
+# Where to find gnuradio include files in the current build tree
+GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/general \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/filter \
+                    -I$(top_srcdir)/gnuradio-core/src/lib/reed-solomon \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/io \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/g72x \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/omnithread \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/swig \
+                    -I$(top_builddir)/gnuradio-core/src/lib/swig \
+                   $(FFTW3F_CFLAGS)
+
+# These used to be set in PKGCONFIG but now point to the current
+# build tree.
+GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
+                     -lgnuradio-core -lfftw3f -lm
+
+GNURADIO_I = $(top_builddir)/gnuradio-core/src/lib/swig/gnuradio.i
+
+# The below used to be set in PKGCONFIG but now point to the current
+# build tree.
+USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
+               -I$(top_srcdir)/usrp/firmware/include
+
+USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
+           -lusrp
+
+# This used to be set in configure.ac but is now defined here for all 
+# Makefiles when this fragment is included.
+STD_DEFINES_AND_INCLUDES=$(DEFINES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)