Changed $(builddir) to ".", since it should always be that.
[debian/gnuradio] / Makefile.common
index f7c88b0d97e42b0ed09996abcf920caa777c13c9..da483d1a1e5bfa5607a6e588ff32a39d57cc48e1 100644 (file)
@@ -1,6 +1,6 @@
 # -*- Makefile -*-
 #
-# Copyright 2004,2006,2007,2008 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -49,6 +49,10 @@ gcellspuincludedir = $(includedir)/gcell/spu
 # Cell spu libs
 libspudir = $(libdir)spu
 
+# This used to be set in configure.ac but is now defined here for all 
+# Makefiles when this fragment is included.
+STD_DEFINES_AND_INCLUDES = $(DEFINES) $(BOOST_CPPFLAGS) \
+       $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
 
 # when including for compilation from pre-installed libraries and such,
 # need to make sure those are put last on the compile command
@@ -56,7 +60,19 @@ WITH_INCLUDES = @with_INCLUDES@
 WITH_SWIG_INCLUDES = @with_SWIG_INCLUDES@
 
 # swig flags
-SWIGPYTHONFLAGS = -fvirtual -python -modern
+# -w511 turns off keyword argument warning
+# "-outdir $(builddir)" writes all generated output files to
+#   the local builddir (which should always be '.')
+SWIG_PYTHON_FLAGS = -fvirtual -python -modern -keyword \
+       -w511 -outdir .
+
+# standard swig flags used by most components
+STD_SWIG_PYTHON_ARGS = \
+       $(SWIG_PYTHON_FLAGS) \
+       $(STD_DEFINES_AND_INCLUDES) \
+       $(LOCAL_SWIG_DEFINES_AND_INCLUDES) \
+       $(WITH_SWIG_INCLUDES) \
+       $(WITH_INCLUDES)
 
 # How to link in the top-level omnithreads library from inside the tree
 OMNITHREAD_INCLUDES = @omnithread_INCLUDES@
@@ -103,10 +119,6 @@ GCELL_SPU_LA = @gcell_spu_LA@
 # libtool aware wrapper for ppu-embedspu
 GCELL_EMBEDSPU_LIBTOOL = @abs_top_srcdir@/gcell/lib/runtime/gcell-embedspu-libtool
 
-# This used to be set in configure.ac but is now defined here for all 
-# Makefiles when this fragment is included.
-STD_DEFINES_AND_INCLUDES=$(DEFINES) $(BOOST_CPPFLAGS) $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
-
 # Fix for BSD make not defining $(RM).  We define it now in configure.ac
 # using AM_PATH_PROG, but now here have to add a -f to be like GNU make
 RM=$(RM_PROG) -f