Changed $(builddir) to ".", since it should always be that.
[debian/gnuradio] / Makefile.common
index 2976e36dcd7b420f89240df7a19febc742ed2c6b..da483d1a1e5bfa5607a6e588ff32a39d57cc48e1 100644 (file)
@@ -1,6 +1,6 @@
 # -*- Makefile -*-
 #
-# Copyright 2004,2006,2007 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -23,9 +23,9 @@
 AM_CXXFLAGS = @autoconf_default_CXXFLAGS@
 
 # includes
-grincludedir   = $(includedir)/gnuradio
+grincludedir = $(includedir)/gnuradio
 
-# swig includes 
+# swig includes
 swigincludedir = $(grincludedir)/swig
 
 # Install the gnuradio stuff in the appropriate subdirectory
@@ -42,53 +42,82 @@ grpyexecdir = $(pyexecdir)/gnuradio
 usrppythondir = $(pythondir)/usrpm
 usrppyexecdir = $(pyexecdir)/usrpm
 
+# gcell includes
+gcellincludedir = $(includedir)/gcell
+gcellspuincludedir = $(includedir)/gcell/spu
+
+# Cell spu libs
+libspudir = $(libdir)spu
+
+# This used to be set in configure.ac but is now defined here for all 
+# Makefiles when this fragment is included.
+STD_DEFINES_AND_INCLUDES = $(DEFINES) $(BOOST_CPPFLAGS) \
+       $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
+
+# when including for compilation from pre-installed libraries and such,
+# need to make sure those are put last on the compile command
+WITH_INCLUDES = @with_INCLUDES@
+WITH_SWIG_INCLUDES = @with_SWIG_INCLUDES@
 
 # swig flags
-SWIGPYTHONFLAGS = -fvirtual -python -modern
+# -w511 turns off keyword argument warning
+# "-outdir $(builddir)" writes all generated output files to
+#   the local builddir (which should always be '.')
+SWIG_PYTHON_FLAGS = -fvirtual -python -modern -keyword \
+       -w511 -outdir .
+
+# standard swig flags used by most components
+STD_SWIG_PYTHON_ARGS = \
+       $(SWIG_PYTHON_FLAGS) \
+       $(STD_DEFINES_AND_INCLUDES) \
+       $(LOCAL_SWIG_DEFINES_AND_INCLUDES) \
+       $(WITH_SWIG_INCLUDES) \
+       $(WITH_INCLUDES)
+
+# How to link in the top-level omnithreads library from inside the tree
+OMNITHREAD_INCLUDES = @omnithread_INCLUDES@
+OMNITHREAD_LA = @omnithread_LA@
 
 # Where to find gnuradio include files in the current build tree
 # top_srcdir for original stuff, top_builddir for generated files
-GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/general \
-                   -I$(top_builddir)/gnuradio-core/src/lib/general \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/gengen \
-                   -I$(top_builddir)/gnuradio-core/src/lib/gengen \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/filter \
-                   -I$(top_builddir)/gnuradio-core/src/lib/filter \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/reed-solomon \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/io \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/g72x \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/swig \
-                   -I$(top_builddir)/gnuradio-core/src/lib/swig \
-                   $(FFTW3F_CFLAGS)
-
-# How to link in the top-level omnithreads library from inside the tree
-OMNITHREAD_INCLUDES = -I$(top_srcdir)/omnithread
-OMNITHREAD_LA = $(top_builddir)/omnithread/libgromnithread.la
+GNURADIO_INCLUDES = @gnuradio_core_INCLUDES@
 
 # How to link in GNU Radio core library from inside the tree
-GNURADIO_CORE_LA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
+GNURADIO_CORE_LA = @gnuradio_core_LA@
 
 # This is a dependency for many swig operations
-GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
+GNURADIO_I = @gnuradio_core_I@
 
 # How to link in the USRP library from inside the tree
-USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib/legacy \
-               -I$(top_srcdir)/usrp/host/lib/inband \
-               -I$(top_srcdir)/usrp/firmware/include
-USRP_LA = $(top_builddir)/usrp/host/lib/legacy/libusrp.la
+GRUEL_INCLUDES = @gruel_INCLUDES@
+GRUEL_LA = @gruel_LA@
+
+# How to link in the USRP library from inside the tree
+USRP_INCLUDES = @usrp_INCLUDES@
+USRP_LA = @usrp_LA@
+
+# How to link in usrp-inband library from inside the tree
+USRP_INBAND_INCLUDES = @usrp_inband_INCLUDES@
+USRP_INBAND_LA = @usrp_inband_LA@
 
 # How to link the PMT library from inside the tree
-PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
-PMT_LA = $(top_builddir)/pmt/src/lib/libpmt.la
+PMT_INCLUDES = @pmt_INCLUDES@
+PMT_LA = @pmt_LA@
 
 # How to link the mblock library from inside the tree
-MBLOCK_INCLUDES = -I$(top_srcdir)/mblock/src/lib
-MBLOCK_LA = $(top_builddir)/mblock/src/lib/libmblock.la
+MBLOCK_INCLUDES = @mblock_INCLUDES@
+MBLOCK_LA = @mblock_LA@
 
-# This used to be set in configure.ac but is now defined here for all 
-# Makefiles when this fragment is included.
-STD_DEFINES_AND_INCLUDES=$(DEFINES) $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
+# How to link the gcell library from inside the tree (the PPU part)
+GCELL_INCLUDES = @gcell_INCLUDES@
+GCELL_LA = @gcell_LA@
+
+# How to link the gcell library from inside the tree (the SPU part)
+GCELL_SPU_INCLUDES = @gcell_spu_INCLUDES@
+GCELL_SPU_LA = @gcell_spu_LA@
+
+# libtool aware wrapper for ppu-embedspu
+GCELL_EMBEDSPU_LIBTOOL = @abs_top_srcdir@/gcell/lib/runtime/gcell-embedspu-libtool
 
 # Fix for BSD make not defining $(RM).  We define it now in configure.ac
 # using AM_PATH_PROG, but now here have to add a -f to be like GNU make
@@ -99,3 +128,6 @@ COMPILE_MBH = $(RUN_GUILE) $(top_srcdir)/mblock/src/scheme/gnuradio/compile-mbh.
 
 # Base directory for example applications
 exampledir = $(datadir)/gnuradio/examples
+
+# Base directory for documentation (docdir undefined in autoconf < 1.60)
+gr_docdir = $(if $(docdir),$(docdir),$(datadir)/doc/$(PACKAGE))-$(VERSION)