Merged r10288:10370 from michaelld/swigpythonargs into trunk. Passes distcheck.
[debian/gnuradio] / Makefile.common
index 35cd1a300e1588d70eb7e80607fa97a33c878c02..c8a801a3a3ae1ba6579c2c4a0795db4aaf54dbbf 100644 (file)
@@ -1,6 +1,6 @@
 # -*- Makefile -*-
 #
-# Copyright 2004,2006,2007,2008 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -49,6 +49,10 @@ gcellspuincludedir = $(includedir)/gcell/spu
 # Cell spu libs
 libspudir = $(libdir)spu
 
+# This used to be set in configure.ac but is now defined here for all 
+# Makefiles when this fragment is included.
+STD_DEFINES_AND_INCLUDES = $(DEFINES) $(BOOST_CPPFLAGS) \
+       $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
 
 # when including for compilation from pre-installed libraries and such,
 # need to make sure those are put last on the compile command
@@ -57,7 +61,18 @@ WITH_SWIG_INCLUDES = @with_SWIG_INCLUDES@
 
 # swig flags
 # -w511 turns off keyword argument warning
-SWIGPYTHONFLAGS = -fvirtual -python -modern -keyword -w511
+# "-outdir $(builddir)" writes all generated output files to
+#   the local builddir (which should always be '.')
+SWIG_PYTHON_FLAGS = -fvirtual -python -modern -keyword \
+       -w511 -outdir $(builddir)
+
+# standard swig flags used by most components
+STD_SWIG_PYTHON_ARGS = \
+       $(SWIG_PYTHON_FLAGS) \
+       $(STD_DEFINES_AND_INCLUDES) \
+       $(LOCAL_SWIG_DEFINES_AND_INCLUDES) \
+       $(WITH_SWIG_INCLUDES) \
+       $(WITH_INCLUDES)
 
 # How to link in the top-level omnithreads library from inside the tree
 OMNITHREAD_INCLUDES = @omnithread_INCLUDES@
@@ -104,10 +119,6 @@ GCELL_SPU_LA = @gcell_spu_LA@
 # libtool aware wrapper for ppu-embedspu
 GCELL_EMBEDSPU_LIBTOOL = @abs_top_srcdir@/gcell/lib/runtime/gcell-embedspu-libtool
 
-# This used to be set in configure.ac but is now defined here for all 
-# Makefiles when this fragment is included.
-STD_DEFINES_AND_INCLUDES=$(DEFINES) $(BOOST_CPPFLAGS) $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
-
 # Fix for BSD make not defining $(RM).  We define it now in configure.ac
 # using AM_PATH_PROG, but now here have to add a -f to be like GNU make
 RM=$(RM_PROG) -f