Fix missed setting from r10598 .
[debian/gnuradio] / Makefile.common
index 35cd1a300e1588d70eb7e80607fa97a33c878c02..b81433a32972d74e7164c1785869f38fbd12f84e 100644 (file)
@@ -1,6 +1,6 @@
 # -*- Makefile -*-
 #
-# Copyright 2004,2006,2007,2008 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -49,16 +49,16 @@ gcellspuincludedir = $(includedir)/gcell/spu
 # Cell spu libs
 libspudir = $(libdir)spu
 
+# This used to be set in configure.ac but is now defined here for all 
+# Makefiles when this fragment is included.
+STD_DEFINES_AND_INCLUDES = $(DEFINES) $(BOOST_CPPFLAGS) \
+       $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
 
 # when including for compilation from pre-installed libraries and such,
 # need to make sure those are put last on the compile command
 WITH_INCLUDES = @with_INCLUDES@
 WITH_SWIG_INCLUDES = @with_SWIG_INCLUDES@
 
-# swig flags
-# -w511 turns off keyword argument warning
-SWIGPYTHONFLAGS = -fvirtual -python -modern -keyword -w511
-
 # How to link in the top-level omnithreads library from inside the tree
 OMNITHREAD_INCLUDES = @omnithread_INCLUDES@
 OMNITHREAD_LA = @omnithread_LA@
@@ -70,9 +70,6 @@ GNURADIO_INCLUDES = @gnuradio_core_INCLUDES@
 # How to link in GNU Radio core library from inside the tree
 GNURADIO_CORE_LA = @gnuradio_core_LA@
 
-# This is a dependency for many swig operations
-GNURADIO_I = @gnuradio_core_I@
-
 # How to link in the USRP library from inside the tree
 GRUEL_INCLUDES = @gruel_INCLUDES@
 GRUEL_LA = @gruel_LA@
@@ -104,10 +101,6 @@ GCELL_SPU_LA = @gcell_spu_LA@
 # libtool aware wrapper for ppu-embedspu
 GCELL_EMBEDSPU_LIBTOOL = @abs_top_srcdir@/gcell/lib/runtime/gcell-embedspu-libtool
 
-# This used to be set in configure.ac but is now defined here for all 
-# Makefiles when this fragment is included.
-STD_DEFINES_AND_INCLUDES=$(DEFINES) $(BOOST_CPPFLAGS) $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
-
 # Fix for BSD make not defining $(RM).  We define it now in configure.ac
 # using AM_PATH_PROG, but now here have to add a -f to be like GNU make
 RM=$(RM_PROG) -f
@@ -119,4 +112,16 @@ COMPILE_MBH = $(RUN_GUILE) $(top_srcdir)/mblock/src/scheme/gnuradio/compile-mbh.
 exampledir = $(datadir)/gnuradio/examples
 
 # Base directory for documentation (docdir undefined in autoconf < 1.60)
-gr_docdir = $(if $(docdir),$(docdir),$(datadir)/doc/$(PACKAGE))-$(VERSION)
+docdir ?= $(datadir)/doc/$(PACKAGE)
+gr_docdir = $(docdir)-$(VERSION)
+
+# Other common defines; use "+=" to add to these
+STAMPS =
+MOSTLYCLEANFILES = $(BUILT_SOURCES) $(STAMPS) *.pyc *.pyo *~ *.tmp *.loT
+
+# Don't distribute the files defined in the variable 'no_dist_files'
+dist-hook:
+       @for file in $(no_dist_files); do \
+               echo $(RM) $(distdir)/$$file; \
+               $(RM) $(distdir)/$$file; \
+       done;