Fix ticket:133 for gr-howto-write-a-block
[debian/gnuradio] / Makefile.common
index 3bf752f98f74bd06d520b7aa2d857e258f11fa33..56d7f5caa0d9c07d93681354b1e6ef1513921a69 100644 (file)
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
+AM_CXXFLAGS = @autoconf_default_CXXFLAGS@
+
 # includes
 grincludedir   = $(includedir)/gnuradio
 
@@ -41,12 +43,13 @@ SWIGPYTHONFLAGS = -fvirtual -python -modern
 GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
                    -I$(top_srcdir)/gnuradio-core/src/lib/general \
                    -I$(top_builddir)/gnuradio-core/src/lib/general \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/gengen \
+                   -I$(top_builddir)/gnuradio-core/src/lib/gengen \
                    -I$(top_srcdir)/gnuradio-core/src/lib/filter \
                    -I$(top_builddir)/gnuradio-core/src/lib/filter \
                    -I$(top_srcdir)/gnuradio-core/src/lib/reed-solomon \
                    -I$(top_srcdir)/gnuradio-core/src/lib/io \
                    -I$(top_srcdir)/gnuradio-core/src/lib/g72x \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/omnithread \
                    -I$(top_srcdir)/gnuradio-core/src/lib/swig \
                    -I$(top_builddir)/gnuradio-core/src/lib/swig \
                    $(FFTW3F_CFLAGS)
@@ -54,6 +57,7 @@ GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
 
 # These used to be set in PKGCONFIG but now point to the current
 # build tree.
+# FIXME shouldn't -lfftw3f -lm just be extracted from libgnuradio-core.la ???
 GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
                      -lgnuradio-core -lfftw3f -lm
 
@@ -65,12 +69,17 @@ GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
 USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
                -I$(top_srcdir)/usrp/firmware/include
 
-USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
-           -lusrp
+USRP_LIBS = -L$(top_builddir)/usrp/host/lib -lusrp
+
+PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
+PMT_LIBS = -L$(top_builddir)/pmt/src/lib -lpmt
+
+OMNITHREAD_INCLUDES = -I$(top_srcdir)/omnithread
+OMNITHREAD_LIBS = -L$(top_builddir)/omnithread -lgromnithread
 
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
-STD_DEFINES_AND_INCLUDES=$(DEFINES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
+STD_DEFINES_AND_INCLUDES=$(DEFINES) $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
 
 # Fix for BSD make not defining $(RM).  We define it now in configure.ac
 # using AM_PATH_PROG, but now here have to add a -f to be like GNU make