merged in mblock work-in-progress
[debian/gnuradio] / Makefile.common
index 1e4395a7eae4b56945eb429a5b5983edf4de93ec..4ce123befed26bc1b1b4e66fb5f8f9d1380364c1 100644 (file)
@@ -36,5 +36,45 @@ grpyexecdir = $(pyexecdir)/gnuradio
 # swig flags
 SWIGPYTHONFLAGS = -fvirtual -python -modern
 
-# gnuradio-core library link command
-GNURADIO_CORE_LIBS = -L$(top_srcdir)/gnuradio-core/src/lib -lgnuradio-core -lfftw3f -lm
+# Where to find gnuradio include files in the current build tree
+# top_srcdir for original stuff, top_builddir for generated files
+GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/general \
+                   -I$(top_builddir)/gnuradio-core/src/lib/general \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/filter \
+                   -I$(top_builddir)/gnuradio-core/src/lib/filter \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/reed-solomon \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/io \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/g72x \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/omnithread \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/swig \
+                   -I$(top_builddir)/gnuradio-core/src/lib/swig \
+                   $(FFTW3F_CFLAGS)
+
+
+# These used to be set in PKGCONFIG but now point to the current
+# build tree.
+GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
+                     -lgnuradio-core -lfftw3f -lm
+
+# This is a dependency for many swig operations
+GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
+
+# The below used to be set in PKGCONFIG but now point to the current
+# build tree.
+USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
+               -I$(top_srcdir)/usrp/firmware/include
+
+USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
+           -lusrp
+
+PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
+PMT_LIBS = -L$(top_builddir)/pmt/src/lib -lpmt
+
+# This used to be set in configure.ac but is now defined here for all 
+# Makefiles when this fragment is included.
+STD_DEFINES_AND_INCLUDES=$(DEFINES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
+
+# Fix for BSD make not defining $(RM).  We define it now in configure.ac
+# using AM_PATH_PROG, but now here have to add a -f to be like GNU make
+RM=$(RM_PROG) -f