Fixes for ticket:35, allowing use of BSD make instead of GNU make.
[debian/gnuradio] / Makefile.common
index f0f02119abd5227b9662b6feeb59a1497f83735b..3bf752f98f74bd06d520b7aa2d857e258f11fa33 100644 (file)
@@ -37,28 +37,33 @@ grpyexecdir = $(pyexecdir)/gnuradio
 SWIGPYTHONFLAGS = -fvirtual -python -modern
 
 # Where to find gnuradio include files in the current build tree
+# top_srcdir for original stuff, top_builddir for generated files
 GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
                    -I$(top_srcdir)/gnuradio-core/src/lib/general \
+                   -I$(top_builddir)/gnuradio-core/src/lib/general \
                    -I$(top_srcdir)/gnuradio-core/src/lib/filter \
-                    -I$(top_srcdir)/gnuradio-core/src/lib/reed-solomon \
+                   -I$(top_builddir)/gnuradio-core/src/lib/filter \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/reed-solomon \
                    -I$(top_srcdir)/gnuradio-core/src/lib/io \
                    -I$(top_srcdir)/gnuradio-core/src/lib/g72x \
                    -I$(top_srcdir)/gnuradio-core/src/lib/omnithread \
                    -I$(top_srcdir)/gnuradio-core/src/lib/swig \
-                    -I$(top_builddir)/gnuradio-core/src/lib/swig \
+                   -I$(top_builddir)/gnuradio-core/src/lib/swig \
                    $(FFTW3F_CFLAGS)
 
+
 # These used to be set in PKGCONFIG but now point to the current
 # build tree.
 GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
                      -lgnuradio-core -lfftw3f -lm
 
-GNURADIO_I = $(top_builddir)/gnuradio-core/src/lib/swig/gnuradio.i
+# This is a dependency for many swig operations
+GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
 
 # The below used to be set in PKGCONFIG but now point to the current
 # build tree.
 USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
-               -I$(top_srcdir)/usrp/firmware/include
+               -I$(top_srcdir)/usrp/firmware/include
 
 USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
            -lusrp
@@ -66,3 +71,7 @@ USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
 STD_DEFINES_AND_INCLUDES=$(DEFINES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
+
+# Fix for BSD make not defining $(RM).  We define it now in configure.ac
+# using AM_PATH_PROG, but now here have to add a -f to be like GNU make
+RM=$(RM_PROG) -f