Fixes for ticket:35, allowing use of BSD make instead of GNU make.
[debian/gnuradio] / Makefile.common
index bd25233edb053ec8987e5be38883403e3733f455..3bf752f98f74bd06d520b7aa2d857e258f11fa33 100644 (file)
@@ -71,3 +71,7 @@ USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
 STD_DEFINES_AND_INCLUDES=$(DEFINES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
+
+# Fix for BSD make not defining $(RM).  We define it now in configure.ac
+# using AM_PATH_PROG, but now here have to add a -f to be like GNU make
+RM=$(RM_PROG) -f