fixed ticket #65
[debian/gnuradio] / Makefile.common
index bd25233edb053ec8987e5be38883403e3733f455..31bf0839cc709b075626f822a4f20761902d1d89 100644 (file)
@@ -16,8 +16,8 @@
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
 # includes
@@ -68,6 +68,13 @@ USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
 USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
            -lusrp
 
+PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
+PMT_LIBS = -L$(top_builddir)/pmt/src/lib -lpmt
+
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
 STD_DEFINES_AND_INCLUDES=$(DEFINES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
+
+# Fix for BSD make not defining $(RM).  We define it now in configure.ac
+# using AM_PATH_PROG, but now here have to add a -f to be like GNU make
+RM=$(RM_PROG) -f