Merged r4605:4612 from jcorgan/glfsr branch into trunk. Implements Galois LFSR sourc...
[debian/gnuradio] / Makefile.common
index f0f02119abd5227b9662b6feeb59a1497f83735b..11bc65abce009558160f67a1fde33f04c0cbe7ed 100644 (file)
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
+AM_CXXFLAGS = @autoconf_default_CXXFLAGS@
+
 # includes
 grincludedir   = $(includedir)/gnuradio
 
@@ -37,32 +39,51 @@ grpyexecdir = $(pyexecdir)/gnuradio
 SWIGPYTHONFLAGS = -fvirtual -python -modern
 
 # Where to find gnuradio include files in the current build tree
+# top_srcdir for original stuff, top_builddir for generated files
 GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
                    -I$(top_srcdir)/gnuradio-core/src/lib/general \
+                   -I$(top_builddir)/gnuradio-core/src/lib/general \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/gengen \
+                   -I$(top_builddir)/gnuradio-core/src/lib/gengen \
                    -I$(top_srcdir)/gnuradio-core/src/lib/filter \
-                    -I$(top_srcdir)/gnuradio-core/src/lib/reed-solomon \
+                   -I$(top_builddir)/gnuradio-core/src/lib/filter \
+                   -I$(top_srcdir)/gnuradio-core/src/lib/reed-solomon \
                    -I$(top_srcdir)/gnuradio-core/src/lib/io \
                    -I$(top_srcdir)/gnuradio-core/src/lib/g72x \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/omnithread \
                    -I$(top_srcdir)/gnuradio-core/src/lib/swig \
-                    -I$(top_builddir)/gnuradio-core/src/lib/swig \
+                   -I$(top_builddir)/gnuradio-core/src/lib/swig \
                    $(FFTW3F_CFLAGS)
 
-# These used to be set in PKGCONFIG but now point to the current
-# build tree.
-GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
-                     -lgnuradio-core -lfftw3f -lm
+# How to link in the top-level omnithreads library
+OMNITHREAD_INCLUDES = -I$(top_srcdir)/omnithread
+OMNITHREAD_LIBS = -L$(top_builddir)/omnithread -lgromnithread
+
+# How to link in GNU Radio core library
+# Note: Win32 libtool cannot extract DLL dependencies already stored in
+# libgnuradio-core, so the core's dependencies must be repeated here
+# This is redundant but harmless on non-Win32 platforms
+GNURADIO_CORE_LIBS = $(OMNITHREAD_LIBS)                                \
+                    $(FFTW3F_LIBS)                             \
+                    -L$(top_builddir)/gnuradio-core/src/lib    \
+                     -lgnuradio-core
 
-GNURADIO_I = $(top_builddir)/gnuradio-core/src/lib/swig/gnuradio.i
+# This is a dependency for many swig operations
+GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
 
 # The below used to be set in PKGCONFIG but now point to the current
 # build tree.
 USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
-               -I$(top_srcdir)/usrp/firmware/include
+               -I$(top_srcdir)/usrp/firmware/include
 
-USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
-           -lusrp
+USRP_LIBS = -L$(top_builddir)/usrp/host/lib -lusrp
+
+PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
+PMT_LIBS = -L$(top_builddir)/pmt/src/lib -lpmt
 
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
-STD_DEFINES_AND_INCLUDES=$(DEFINES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
+STD_DEFINES_AND_INCLUDES=$(DEFINES) $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
+
+# Fix for BSD make not defining $(RM).  We define it now in configure.ac
+# using AM_PATH_PROG, but now here have to add a -f to be like GNU make
+RM=$(RM_PROG) -f