apply diff from previous commits
[debian/gnuradio] / Makefile.am
index e8328c263963e6e5b043138246b751af6484cb9e..ec71be725bff59bd746c9f6d8e4b5b667ce6fca7 100644 (file)
@@ -37,3 +37,16 @@ EXTRA_DIST = \
 
 SUBDIRS = @build_dirs@
 DIST_SUBDIRS = @build_dirs@ @skipped_dirs@ @with_dirs@
+
+if PYTHON
+
+export pythondir
+
+install-data-hook:
+       @if ! python -c "import gnuradio" > /dev/null 2>&1; then\
+               printf "\n*** Post-Install Message ***\
+               \nWarning: python could not find the gnuradio module.\
+               \nMake sure that $${pythondir} is in your PYTHONPATH\n\n";\
+       fi
+
+endif