Adding features and usability.
[debian/gnuradio] / Makefile.am
index 32a7d4379ca6f3fc2087729d96023e6491c524b7..e8328c263963e6e5b043138246b751af6484cb9e 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2001,2006 Free Software Foundation, Inc.
+# Copyright 2001,2006,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
+ACLOCAL_AMFLAGS = -I config
+
 include $(top_srcdir)/Makefile.common
 
-EXTRA_DIST =                           \
-       bootstrap                       \
-       configure                       \
-       config.h.in
+EXTRA_DIST = \
+       bootstrap \
+       configure \
+       configure-cell-cross \
+       config.h.in \
+       run_tests.sh.in \
+       Makefile.swig \
+       Makefile.swig.gen.t \
+       Makefile.par.gen \
+       Makefile.gen.gen \
+       debian/changelog
 
-SUBDIRS = @subdirs@
-DIST_SUBDIRS = @subdirs@ @failed_subdirs@
+SUBDIRS = @build_dirs@
+DIST_SUBDIRS = @build_dirs@ @skipped_dirs@ @with_dirs@