tests: port to systems for which ":" is not the PATH separator
[debian/gzip] / Makefile.am
index 90fff2da845f0822be9a31229ea66b09a9fd257b..dfed9aac09f3e47f76b60cebfd8073ac7f65b54d 100644 (file)
@@ -1,6 +1,6 @@
 # Make gzip (GNU zip).
 
-# Copyright (C) 1999, 2001-2002, 2006-2007, 2009-2012 Free Software Foundation,
+# Copyright (C) 1999, 2001-2002, 2006-2007, 2009-2016 Free Software Foundation,
 # Inc.
 
 # This program is free software; you can redistribute it and/or modify
@@ -21,7 +21,6 @@ ALL_RECURSIVE_TARGETS =
 BUILT_SOURCES =
 
 SUBDIRS = lib doc . tests
-ACLOCAL_AMFLAGS = -I m4
 AM_CPPFLAGS = -I$(top_srcdir)/lib
 AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
@@ -83,7 +82,6 @@ SUFFIXES = .in
 .in:
        $(AM_V_GEN)sed \
                -e 's|/bin/sh|$(SHELL)|g' \
-               -e 's|[@]bindir@|'\''$(bindir)'\''|g' \
                -e 's|[@]GREP@|$(GREP)|g' \
                -e 's|[@]VERSION@|$(VERSION)|g' \
                $(srcdir)/$@.in >$@-t \
@@ -105,20 +103,27 @@ gen-ChangeLog:
          mv $(distdir)/cl-t $(distdir)/ChangeLog;                      \
        fi
 
+# Prepend "." to $PATH:
+new_path = PATH=.$(PATH_SEPARATOR)$$PATH
+
 # A simple test, just of gzip -- more of a sanity check than anything else.
 FILES_TO_CHECK = $(bin_SCRIPTS) \
   $(top_srcdir)/ChangeLog $(top_srcdir)/configure $(top_srcdir)/gzip.c
 check-local: $(FILES_TO_CHECK) $(bin_PROGRAMS) gzip.doc.gz
-       { test '$(srcdir)' != . || ./zdiff --__bindir . -c gzip.doc.gz; }
-       ./zdiff --__bindir . -c $(srcdir)/gzip.doc $(srcdir)/gzip.doc
-       ./zdiff --__bindir . $(srcdir)/gzip.doc gzip.doc.gz
-       ./zdiff --__bindir . -c - $(srcdir)/gzip.doc <gzip.doc.gz
-       ./zdiff --__bindir . -c gzip.doc.gz gzip.doc.gz
-       ./zgrep --__bindir . -iV >/dev/null
-       for file in $(FILES_TO_CHECK); do \
-         ./gzip -cv -- "$$file" | ./gzip -d | cmp - "$$file" || exit 1; \
+       $(AM_V_GEN)$(new_path); { test '$(srcdir)' != . \
+                                   || zdiff -c gzip.doc.gz; }
+       $(AM_V_at)$(new_path); zdiff -c $(srcdir)/gzip.doc $(srcdir)/gzip.doc
+       $(AM_V_at)$(new_path); zdiff $(srcdir)/gzip.doc gzip.doc.gz
+       $(AM_V_at)$(new_path); zdiff -c - $(srcdir)/gzip.doc <gzip.doc.gz
+       $(AM_V_at)$(new_path); zdiff -c gzip.doc.gz gzip.doc.gz
+       $(AM_V_at)$(new_path); zgrep -iV >/dev/null
+       $(AM_V_at)$(new_path);                          \
+       for opt in --rsyncable '' -1 -9; do             \
+          for file in $(FILES_TO_CHECK); do            \
+            gzip $$opt -c -- "$$file"                  \
+              | gzip -d | cmp - "$$file" || exit 1;    \
+          done;                                                \
        done
-       @echo 'Test succeeded.'
 
 install-exec-hook: remove-installed-links
 install-exec-hook remove-installed-links: