leave user backup in groups disk and tape on purge in case sys admin has
[debian/amanda] / Makefile.am
index 532bccec18301ebcf6d94f9ac5c615626a02dae0..dcbb1bc30da175a5f7e133d01ae9cb17fa5db135 100644 (file)
@@ -1,20 +1,16 @@
 ## Process this file with automake to produce Makefile.in
 AUTOMAKE_OPTIONS = 1.4 foreign
 
-ACINCLUDE_M4 = $(srcdir)/acinclude.m4
-ACINCLUDE_M4I = $(srcdir)/config/acinclude.m4i
-LIBTOOL_M4I = $(srcdir)/config/libtool.m4i
-GNULIB_M4I  = $(srcdir)/config/gnulib.m4i
-ACINCLUDE_M4_DEPS = $(GNULIB_M4I) $(ACINCLUDE_M4I) $(LIBTOOL_M4I)
+include $(top_srcdir)/config/automake/vars.am
+include $(top_srcdir)/config/automake/installperms.am
+
+ACLOCAL_AMFLAGS = --force -I . -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
 
 if WANT_CLIENT
-CLIENT_SUBDIRS = client-src dumper-src
-endif
-if WANT_TAPE
-TAPE_SUBDIRS = tape-src
+CLIENT_SUBDIRS = client-src application-src
 endif
 if WANT_SERVER
-SERVER_SUBDIRS = server-src changer-src
+SERVER_SUBDIRS = device-src server-src changer-src xfer-src
 endif
 if WANT_RESTORE
 RESTORE_SUBDIRS = restore-src
@@ -26,10 +22,11 @@ if WANT_AMPLOT
 PLOT_SUBDIRS = amplot
 endif
 # order is significant, don't change it arbitrarily
-SUBDIRS = \
+SUBDIRS = \
        gnulib \
        config \
        common-src \
+       amar-src \
        amandad-src \
        $(TAPE_SUBDIRS) \
        $(CLIENT_SUBDIRS) \
@@ -37,13 +34,20 @@ SUBDIRS = \
        $(RESTORE_SUBDIRS) \
        $(RECOVER_SUBDIRS) \
        $(PLOT_SUBDIRS) \
-       man docs example
+       perl \
+       po \
+       man \
+       example \
+       packaging \
+       installcheck
 
 pkgdata_DATA = \
-       ReleaseNotes                    \
-       COPYRIGHT
+       ReleaseNotes    \
+       COPYRIGHT       \
+       NEWS            \
+       ChangeLog
 
-EXTRA_DIST = $(SNAPSHOT_STAMP) \
+EXTRA_DIST += $(SNAPSHOT_STAMP) \
        $(pkgdata_DATA)                 \
         autogen                        \
        contrib/README                  \
@@ -64,15 +68,17 @@ EXTRA_DIST = $(SNAPSHOT_STAMP) \
        contrib/gsc/ucfggsc.c           \
        patches/regex-3.6alpha.patch    \
        patches/samba-largefs.patch     \
-       patches/tar-1.12.patch
-
-$(ACINCLUDE_M4): $(ACINCLUDE_M4_DEPS)
-       @-rm -f $@
-       @cat $(ACINCLUDE_M4_DEPS) > $@
+       patches/tar-1.12.patch          \
+       UPGRADING                       \
+       DEVELOPING
 
 libtool: $(LIBTOOL_DEPS)
        $(SHELL) ./config.status --recheck
 
+# empty out the installperms manifest file when we start
+install-exec-local: installperms-init
+install-data-local: installperms-init
+
 ## This is only meaningful for snapshots, but it won't hurt releases.
 CONFIG_STATUS = config.status
 $(CONFIG_STATUS): $(SNAPSHOT_STAMP)
@@ -88,7 +94,7 @@ lint:
        (cd recover-src; make lint)
        (cd restore-src; make lint)
        (cd server-src; make lint)
-       (cd tape-src; make lint)
+       (cd xfer-src; make lint)
 
 ## Do not release the *.test.c sources.  They get built on the fly and
 ## would contain a path from the distribution machine, which will just
@@ -96,3 +102,7 @@ lint:
 
 dist-hook:
        find $(distdir)/. -name '*.test.c' -exec rm {} \;
+
+# ensure that configure gets the right arguments for distcheck; this keeps the
+# user/group through to the distcheck, rather than defaulting back to 'amanda'.
+DISTCHECK_CONFIGURE_FLAGS = --with-user=$(CLIENT_LOGIN) --with-group=$(SETUID_GROUP) --with-owner=$(BINARY_OWNER) --disable-installperms --without-amperldir --without-force-uid --with-tmpdir=$(AMANDA_TMPDIR) SINGLE_USERID=yes CLOBBER_MY_CONFIG=OK