Imported Upstream version 2.6.0
[debian/amanda] / Makefile.am
index b51faf45c52eeba6210a8ec3b25e41d083d5f95e..b6824ac0578d82e12055982a74c3687032f5e64a 100644 (file)
@@ -1,10 +1,7 @@
 ## Process this file with automake to produce Makefile.in
 AUTOMAKE_OPTIONS = 1.4 foreign
 
-ACINCLUDE_M4 = $(srcdir)/acinclude.m4
-ACINCLUDE_M4I = $(srcdir)/config/acinclude.m4i
-LIBTOOL_M4I = $(srcdir)/config/libtool.m4i
-ACINCLUDE_M4_DEPS = $(ACINCLUDE_M4I) $(LIBTOOL_M4I)
+ACLOCAL_AMFLAGS = --force -I . -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
 
 if WANT_CLIENT
 CLIENT_SUBDIRS = client-src dumper-src
@@ -13,7 +10,7 @@ if WANT_TAPE
 TAPE_SUBDIRS = tape-src
 endif
 if WANT_SERVER
-SERVER_SUBDIRS = server-src changer-src
+SERVER_SUBDIRS = device-src server-src changer-src
 endif
 if WANT_RESTORE
 RESTORE_SUBDIRS = restore-src
@@ -26,6 +23,7 @@ PLOT_SUBDIRS = amplot
 endif
 # order is significant, don't change it arbitrarily
 SUBDIRS = \
+       gnulib \
        config \
        common-src \
        amandad-src \
@@ -35,13 +33,18 @@ SUBDIRS = \
        $(RESTORE_SUBDIRS) \
        $(RECOVER_SUBDIRS) \
        $(PLOT_SUBDIRS) \
-       man docs example
+       perl \
+       po \
+       man \
+       example \
+       packaging \
+       installcheck
 
 pkgdata_DATA = \
-       ReleaseNotes                    \
-       COPYRIGHT                       \
-       COPYRIGHT-APACHE                \
-       COPYRIGHT-REGEX
+       ReleaseNotes    \
+       COPYRIGHT       \
+       NEWS            \
+       ChangeLog
 
 EXTRA_DIST = $(SNAPSHOT_STAMP) \
        $(pkgdata_DATA)                 \
@@ -65,33 +68,8 @@ EXTRA_DIST = $(SNAPSHOT_STAMP) \
        patches/regex-3.6alpha.patch    \
        patches/samba-largefs.patch     \
        patches/tar-1.12.patch          \
-       regex-src/COPYRIGHT             \
-       regex-src/Makefile              \
-       regex-src/README                \
-       regex-src/WHATSNEW              \
-       regex-src/cclass.h              \
-       regex-src/cname.h               \
-       regex-src/debug.c               \
-       regex-src/engine.c              \
-       regex-src/main.c                \
-       regex-src/mkh                   \
-       regex-src/regcomp.c             \
-       regex-src/regerror.c            \
-       regex-src/regex.3               \
-       regex-src/regex.7               \
-       regex-src/regex2.h              \
-       regex-src/regexec.c             \
-       regex-src/regfree.c             \
-       regex-src/split.c               \
-       regex-src/tests                 \
-       regex-src/utils.h               \
-       regex-src/fake/limits.h         \
-       regex-src/fake/memmove.c        \
-       regex-src/fake/stdlib.h
-
-$(ACINCLUDE_M4): $(ACINCLUDE_M4_DEPS)
-       @-rm -f $@
-       @cat $(ACINCLUDE_M4_DEPS) > $@
+       UPGRADING                       \
+       DEVELOPING
 
 libtool: $(LIBTOOL_DEPS)
        $(SHELL) ./config.status --recheck
@@ -109,7 +87,6 @@ lint:
        (cd common-src; make lint)
        (cd oldrecover-src; make lint)
        (cd recover-src; make lint)
-       (cd regex-src; make lint)
        (cd restore-src; make lint)
        (cd server-src; make lint)
        (cd tape-src; make lint)
@@ -120,3 +97,7 @@ lint:
 
 dist-hook:
        find $(distdir)/. -name '*.test.c' -exec rm {} \;
+
+# ensure that configure gets the right arguments for distcheck; this keeps the
+# user/group through to the distcheck, rather than defaulting back to 'amanda'.
+DISTCHECK_CONFIGURE_FLAGS = --with-user=$(CLIENT_LOGIN) --with-group=$(SETUID_GROUP) --with-owner=$(BINARY_OWNER) --disable-installperms --without-force-uid --with-tmpdir=$(AMANDA_TMPDIR) SINGLE_USERID=yes