Imported Upstream version 2.5.1p3
[debian/amanda] / Makefile.am
index 360006876f4c5faca167e6ea5732fa817abd2e1c..b51faf45c52eeba6210a8ec3b25e41d083d5f95e 100644 (file)
@@ -7,7 +7,7 @@ LIBTOOL_M4I = $(srcdir)/config/libtool.m4i
 ACINCLUDE_M4_DEPS = $(ACINCLUDE_M4I) $(LIBTOOL_M4I)
 
 if WANT_CLIENT
-CLIENT_SUBDIRS = client-src
+CLIENT_SUBDIRS = client-src dumper-src
 endif
 if WANT_TAPE
 TAPE_SUBDIRS = tape-src
@@ -19,7 +19,7 @@ if WANT_RESTORE
 RESTORE_SUBDIRS = restore-src
 endif
 if WANT_RECOVER
-RECOVER_SUBDIRS = recover-src
+RECOVER_SUBDIRS = recover-src oldrecover-src
 endif
 if WANT_AMPLOT
 PLOT_SUBDIRS = amplot
@@ -28,8 +28,9 @@ endif
 SUBDIRS = \
        config \
        common-src \
-       $(CLIENT_SUBDIRS) \
+       amandad-src \
        $(TAPE_SUBDIRS) \
+       $(CLIENT_SUBDIRS) \
        $(SERVER_SUBDIRS) \
        $(RESTORE_SUBDIRS) \
        $(RECOVER_SUBDIRS) \
@@ -37,12 +38,14 @@ SUBDIRS = \
        man docs example
 
 pkgdata_DATA = \
+       ReleaseNotes                    \
        COPYRIGHT                       \
        COPYRIGHT-APACHE                \
        COPYRIGHT-REGEX
 
 EXTRA_DIST = $(SNAPSHOT_STAMP) \
        $(pkgdata_DATA)                 \
+        autogen                        \
        contrib/README                  \
        contrib/dbbackup.README         \
        contrib/dbbackup.ksh            \
@@ -50,13 +53,15 @@ EXTRA_DIST = $(SNAPSHOT_STAMP) \
        contrib/dbbackup.tcl            \
        contrib/mkamandisk              \
        contrib/set_prod_link.pl        \
-       contrib/sst/Makefile            \
-       contrib/sst/README              \
-       contrib/sst/README.Amanda       \
-       contrib/sst/sst.c               \
-       contrib/sst/sst.conf            \
-       contrib/sst/sst_def.h           \
-       contrib/sst/sstest.c            \
+       contrib/gsc/README              \
+       contrib/gsc/cfggsc.c            \
+       contrib/gsc/defgsc.c            \
+       contrib/gsc/gsc.add             \
+       contrib/gsc/gscdd.c             \
+       contrib/gsc/gscdds.h            \
+       contrib/gsc/makefile            \
+       contrib/gsc/tstinq.c            \
+       contrib/gsc/ucfggsc.c           \
        patches/regex-3.6alpha.patch    \
        patches/samba-largefs.patch     \
        patches/tar-1.12.patch          \
@@ -97,6 +102,18 @@ $(CONFIG_STATUS): $(SNAPSHOT_STAMP)
 SNAPSHOT:
        : SNAPSHOT file was removed, will reconfigure...
 
+lint:
+       (cd amandad-src; make lint)
+       (cd changer-src; make lint)
+       (cd client-src; make lint)
+       (cd common-src; make lint)
+       (cd oldrecover-src; make lint)
+       (cd recover-src; make lint)
+       (cd regex-src; make lint)
+       (cd restore-src; make lint)
+       (cd server-src; make lint)
+       (cd tape-src; make lint)
+
 ## Do not release the *.test.c sources.  They get built on the fly and
 ## would contain a path from the distribution machine, which will just
 ## confuse the target user.