create a lenny bug fix branch
[debian/amanda] / Makefile.am
index 360006876f4c5faca167e6ea5732fa817abd2e1c..532bccec18301ebcf6d94f9ac5c615626a02dae0 100644 (file)
@@ -4,10 +4,11 @@ AUTOMAKE_OPTIONS = 1.4 foreign
 ACINCLUDE_M4 = $(srcdir)/acinclude.m4
 ACINCLUDE_M4I = $(srcdir)/config/acinclude.m4i
 LIBTOOL_M4I = $(srcdir)/config/libtool.m4i
-ACINCLUDE_M4_DEPS = $(ACINCLUDE_M4I) $(LIBTOOL_M4I)
+GNULIB_M4I  = $(srcdir)/config/gnulib.m4i
+ACINCLUDE_M4_DEPS = $(GNULIB_M4I) $(ACINCLUDE_M4I) $(LIBTOOL_M4I)
 
 if WANT_CLIENT
-CLIENT_SUBDIRS = client-src
+CLIENT_SUBDIRS = client-src dumper-src
 endif
 if WANT_TAPE
 TAPE_SUBDIRS = tape-src
@@ -19,17 +20,19 @@ if WANT_RESTORE
 RESTORE_SUBDIRS = restore-src
 endif
 if WANT_RECOVER
-RECOVER_SUBDIRS = recover-src
+RECOVER_SUBDIRS = recover-src oldrecover-src
 endif
 if WANT_AMPLOT
 PLOT_SUBDIRS = amplot
 endif
 # order is significant, don't change it arbitrarily
 SUBDIRS = \
+       gnulib \
        config \
        common-src \
-       $(CLIENT_SUBDIRS) \
+       amandad-src \
        $(TAPE_SUBDIRS) \
+       $(CLIENT_SUBDIRS) \
        $(SERVER_SUBDIRS) \
        $(RESTORE_SUBDIRS) \
        $(RECOVER_SUBDIRS) \
@@ -37,12 +40,12 @@ SUBDIRS = \
        man docs example
 
 pkgdata_DATA = \
-       COPYRIGHT                       \
-       COPYRIGHT-APACHE                \
-       COPYRIGHT-REGEX
+       ReleaseNotes                    \
+       COPYRIGHT
 
 EXTRA_DIST = $(SNAPSHOT_STAMP) \
        $(pkgdata_DATA)                 \
+        autogen                        \
        contrib/README                  \
        contrib/dbbackup.README         \
        contrib/dbbackup.ksh            \
@@ -50,39 +53,18 @@ EXTRA_DIST = $(SNAPSHOT_STAMP) \
        contrib/dbbackup.tcl            \
        contrib/mkamandisk              \
        contrib/set_prod_link.pl        \
-       contrib/sst/Makefile            \
-       contrib/sst/README              \
-       contrib/sst/README.Amanda       \
-       contrib/sst/sst.c               \
-       contrib/sst/sst.conf            \
-       contrib/sst/sst_def.h           \
-       contrib/sst/sstest.c            \
+       contrib/gsc/README              \
+       contrib/gsc/cfggsc.c            \
+       contrib/gsc/defgsc.c            \
+       contrib/gsc/gsc.add             \
+       contrib/gsc/gscdd.c             \
+       contrib/gsc/gscdds.h            \
+       contrib/gsc/makefile            \
+       contrib/gsc/tstinq.c            \
+       contrib/gsc/ucfggsc.c           \
        patches/regex-3.6alpha.patch    \
        patches/samba-largefs.patch     \
-       patches/tar-1.12.patch          \
-       regex-src/COPYRIGHT             \
-       regex-src/Makefile              \
-       regex-src/README                \
-       regex-src/WHATSNEW              \
-       regex-src/cclass.h              \
-       regex-src/cname.h               \
-       regex-src/debug.c               \
-       regex-src/engine.c              \
-       regex-src/main.c                \
-       regex-src/mkh                   \
-       regex-src/regcomp.c             \
-       regex-src/regerror.c            \
-       regex-src/regex.3               \
-       regex-src/regex.7               \
-       regex-src/regex2.h              \
-       regex-src/regexec.c             \
-       regex-src/regfree.c             \
-       regex-src/split.c               \
-       regex-src/tests                 \
-       regex-src/utils.h               \
-       regex-src/fake/limits.h         \
-       regex-src/fake/memmove.c        \
-       regex-src/fake/stdlib.h
+       patches/tar-1.12.patch
 
 $(ACINCLUDE_M4): $(ACINCLUDE_M4_DEPS)
        @-rm -f $@
@@ -97,6 +79,17 @@ $(CONFIG_STATUS): $(SNAPSHOT_STAMP)
 SNAPSHOT:
        : SNAPSHOT file was removed, will reconfigure...
 
+lint:
+       (cd amandad-src; make lint)
+       (cd changer-src; make lint)
+       (cd client-src; make lint)
+       (cd common-src; make lint)
+       (cd oldrecover-src; make lint)
+       (cd recover-src; make lint)
+       (cd restore-src; make lint)
+       (cd server-src; make lint)
+       (cd tape-src; make lint)
+
 ## Do not release the *.test.c sources.  They get built on the fly and
 ## would contain a path from the distribution machine, which will just
 ## confuse the target user.