don't double patch!
[debian/elilo] / Makefile
index 98d032391fadc03e7dfaab1c8ed239e700f56b60..f0efebd9735cfa47978f883aad77ae9c24fd3b5d 100644 (file)
--- a/Makefile
+++ b/Makefile
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/Make.defaults
-TOPDIR = $(SRCDIR)
+include Make.defaults
+TOPDIR=.
 
 
 CRTOBJS       = $(EFICRT0)/crt0-efi-$(ARCH).o
 LDSCRIPT      = $(EFICRT0)/elf_$(ARCH)_efi.lds
 
 LDFLAGS             += -T $(LDSCRIPT) -shared -Bsymbolic -L$(EFILIB) -L$(GNUEFILIB) $(CRTOBJS)
-LOADLIBES     = -lefi -lgnuefi $(shell $(CC) $(ARCH3264) -print-libgcc-file-name)
+LOADLIBES     = -lefi -lgnuefi $(shell $(CC) -print-libgcc-file-name)
 FORMAT        = efi-app-$(ARCH)
 
 FILESYSTEM    =
@@ -85,14 +81,13 @@ elilo.efi: elilo.so
 
 elilo.so: $(FILES)
 
-elilo.o : elilo.c
+elilo.o : elilo.c $(ARCH)/sysdeps.h
 
 fileops.o : Make.defaults
 chooser.o : Make.defaults
 
 $(SUBDIRS): dummy
-       mkdir -p $@
-       $(MAKE) -C $@ -f $(SRCDIR)/../$@/Makefile SRCDIR=$(SRCDIR)/../$@ ARCH=$(ARCH)
+       $(MAKE) -C $@
 
 dummy:
 
@@ -111,4 +106,4 @@ ifeq ($(GCC_VERSION),2)
        @exit 1
 endif
 
-include $(SRCDIR)/Make.rules
+include Make.rules