update standards version
[debian/elilo] / Makefile
index 5015faf441589b6b789eca2d98903b93e90f0ec4..613b597ee890ac7d8c4b0034702cb74be251ac57 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,8 @@
 #
 #  Copyright (C) 2001-2003 Hewlett-Packard Co.
 #      Contributed by Stephane Eranian <eranian@hpl.hp.com>
+#      Contributed by Fenghua Yu<fenghua.yu@intel.com>
+#      Contributed by Chandramouli Narayanan<mouli@linux.intel.com>
 #
 # This file is part of ELILO, the LINUX EFI boot loader.
 #
@@ -58,10 +60,14 @@ ifeq ($(ARCH),ia32)
 SUBDIRS += ia32
 endif
 
+ifeq ($(ARCH),x86_64)
+SUBDIRS += x86_64
+endif
+
 FILES = elilo.o getopt.o strops.o loader.o \
         fileops.o util.o vars.o alloc.o chooser.o  \
        config.o initrd.o alternate.o bootparams.o \
-       gunzip.o fs/fs.o \
+       gunzip.o console.o fs/fs.o \
        choosers/choosers.o \
        devschemes/devschemes.o \
        $(ARCH)/sysdeps.o \