missed one
[debian/pax] / Makefile
index 8a94849ac9695880c580f594255fb173c84185e7..4cfa56119e262c844b4ff71659c70a87e5200796 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,24 @@
+#      $OpenBSD: Makefile,v 1.10 2001/05/26 00:32:20 millert Exp $
+
+# To install on versions prior to BSD 4.4 the following may have to be
+# defined with CFLAGS +=
+#
+# -DLONG_OFF_T Define this if the base type of an off_t is a long (and is
+#              NOT a quad).  (This is often defined in the file
+#              /usr/include/sys/types.h).
+#              This define is important, as if you do have a quad_t
+#              off_t and define LONG_OFF_T, pax will compile but will
+#              NOT RUN PROPERLY.
+#
+
 PROG=   pax
 SRCS=  ar_io.c ar_subs.c buf_subs.c cache.c cpio.c file_subs.c ftree.c\
        gen_subs.c getoldopt.c options.c pat_rep.c pax.c sel_subs.c tables.c\
-       tar.c tty_subs.c fgetln.c strmode.c
+       tar.c tty_subs.c fgetln.c strmode.c strlcpy.c vis.c
 OBJS=  $(SRCS:.c=.o)
 MAN=   pax.1
 
-CFLAGS= -Wall -O2 -g\
+CFLAGS= -Wall -O2 -g -DLONG_OFF_T\
        -DNET2_STAT -D_PATH_DEFTAPE=\"/dev/rmt0\" -DDEBIAN -D_GNU_SOURCE
 
 prefix=/usr/local
@@ -20,6 +33,6 @@ realclean: clean
        $(RM) $(PROG)
 
 install:
-       install -d -m 755 $(prefix)/bin $(prefix)/share/man/man1
-       install -s -m 755 $(PROG) $(prefix)/bin
-       install    -m 644 $(MAN)  $(prefix)/share/man/man1
+       install -d -m 755 $(DESTDIR)$(prefix)/bin $(DESTDIR)$(prefix)/share/man/man1
+       install -s -m 755 $(PROG) $(DESTDIR)$(prefix)/bin
+       install    -m 644 $(MAN)  $(DESTDIR)$(prefix)/share/man/man1