* Makefile.am (MOSTLYCLEANFILES): Add _match.i.
[debian/gzip] / ChangeLog
index cde2dc58e9cc9b752b284d8273991f1ad0c8d007..c13ed0d5c90b3272ab6fb139c2bc0c45933ab5cc 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,179 @@
+2006-12-15  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * NEWS, configure.ac (AC_INIT):
+       Version 1.3.9 released.
+
+       * Makefile.am (MOSTLYCLEANFILES): Add _match.i.
+
+       * bootstrap (gnulib_tool_options_extras): New var.
+       (gnulib_tool_options): Use it.
+       * bootstrap.conf (gnulib_tool_options_extras): Avoid getline and
+       rpmatch.  gzip doesn't need them, since it doesn't ENABLE_NLS.
+
+2006-12-13  Bruno Haible  <bruno@clisp.org>
+
+       * configure.ac: Use $CPPFLAGS everywhere $CPP is used, and use
+       $CPPFLAGS $CFLAGS everywhere $CC is used.
+       * lib/Makefile.am (match.$(OBJEXT)): Likewise.
+       * configure.ac: Test the exit code of the $CPP and $ASCPPPOST commands
+       separately.
+
+2006-12-11  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * configure.ac (ASCPPPOST): Simplify to use just 'sed'.
+       * lib/Makefile.am (match.$(OBJEXT)): Check for CPP failure.
+
+2006-12-11  Bruno Haible  <bruno@clisp.org>
+
+       Cross-compilation support.
+       * configure.ac (ASCPP): Remove substituted variable.
+       (ASCPPPOST, ASCPPFLAGS): New substituted variables.
+       * lib/Makefile.am (ASCPP, LN_S): Remove unnecessary macro definitions.
+       (match.$(OBJEXT)): Use CPP, ASCPPFLAGS, ASCPPPOST instead of ASCPP.
+       * configure.ac: Add test for chown function.
+       * gzip.c (treat_file) [!HAVE_CHOWN]: Don't call chown.
+       * gzip.c: Include "timespec.h".  This doesn't fix any bugs, but
+       it is clearer.
+
+2006-12-11  Paul Eggert  <eggert@cs.ucla.edu>
+
+       The SSIZE_MAX fix didn't work on NSK, so fix it in a more-reliable
+       (albeit more-complicated) way.  Problem reported by Matthew Woehlke.
+       * gzip.h (read_buffer): New decl.
+       * unlzw.c (unlzw): Use read_buffer rather than read.
+       * zip.c (file_read): Likewise.
+       * util.c (copy, fill_inbuf): Likewise.
+       (read_buffer, write_buffer): New functions.
+       (write_buf): Use write_buffer rather than write.
+
+       Undo the previous SSIZE_MAX-related change; it didn't work.
+       * gzip.c: Include <limits.h>.
+       * util.c: Likewise.
+       * gzip.h: Don't include <limits.h>.
+       (INBUFSIZ): Don't worry about SSIZE_MAX here.
+
+2006-12-08  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * NEWS, configure.ac (AC_INIT):
+       Version 1.3.8 released.
+
+       * gzexe.in (mktemp_status): New var, used to see whether
+       mktemp is a known command.  Use this instead of confounding
+       mktemp's existence with its success.
+
+       * zdiff.in: Remove first line containing ":".  This follows
+       up on the SEDCMD fix of 2006-12-01.
+       * zforce.in: Likewise.
+       * zgrep.in: Likewise.
+       * zless.in: Likewise.
+       * zmore.in: Likewise.
+       * znew.in: Likewise.
+
+       Fix problems in porting to NSK reported by Matthew Woehlke in
+       <http://lists.gnu.org/archive/html/bug-gzip/2006-12/msg00025.html> and
+       <http://lists.gnu.org/archive/html/bug-gzip/2006-12/msg00027.html>.
+       * gzip.h: Include <limits.h>, for SSIZE_MAX.
+       (INBUFSIZE): Don't make it any larger than SSIZE_MAX.
+       Problem reported by Matthew Woehlke in
+       <http://lists.gnu.org/archive/html/bug-gzip/2006-11/msg00013.html>.
+       * gzip.c: Don't include <limits.h>, as gzip.h now does this.
+       * util.c: Likewise.
+       * gzip.c (main): Set exiting_signal before installing signal handlers.
+       (install_signal_handlers): Don't set exiting_signal here.  This
+       fixes a C99ism.
+       * zip.c: Include timespec.h, for time_stamp type.
+
+2006-12-08  Ralf Wildenhues  <Ralf.Wildenhues@gmx.de>  (tiny change)
+
+       * gzexe.in: Work around FreeBSD shell trap bug.
+       * gzip.1: Fix typo.
+       * doc/gzip.texi: Likewise.
+
+2006-12-08  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * .cvsignore: Add .deps, gzexe, gzip, zdiff, zforce, zgrep,
+       zless, zmore, znew.
+       * doc/.cvsignore: Add Makefile.
+       * lib/.cvsignore: Add .deps, Makefile, alloca.h, config.h, fcntl.h,
+       stamp-h1, stdint.h, sys.
+
+       * configure.ac (for assembler): Set ASFLAGS_config to
+       -Wa,--noexecstack if this seems advisable on this platform.
+       Problem reported by Mike Frysinger in
+       <http://lists.gnu.org/archive/html/bug-gzip/2006-12/msg00018.html>.
+       * lib/Makefile.am (match.$(OBJEXT)): Use ASFLAGS_config.
+
+2006-12-07  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * Makefile.am (install-exec-hook): Fix bug when installing
+       symbolic links as aliases.  Problem reported by Mike Frysinger.
+
+       * deflate.c (deflate_fast, deflate): Avoid core dump.  Problem
+       originally reported by Jochen Friedrich and trivial patch supplied
+       by Anthony Towns; see <http://bugs.debian.org/184057>.
+
+2006-12-06  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * NEWS, configure.ac (AC_INIT):
+       Version 1.3.7 released.
+
+2006-12-06  Bruno Haible  <bruno@clisp.org>  (tiny change)
+       and Paul Eggert  <eggert@cs.ucla.edu>
+
+       Fix build failure on case-insensitive file systems.
+       * configure.ac: Use match_.s instead of _match.s.
+       * Makefile.am (MOSTLYCLEANFILES): Likewise.
+       * lib/Makefile.am (match.$(OBJEXT)): Likewise.
+       (MOSTLYCLEANFILES): Likewise.
+
+2006-12-06  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * NEWS: Document the fixes below.
+       * configure.ac (AC_CHECK_FUNCS_ONCE): Add siginterrupt.
+       * gzip.c (lstat) [!defined(HAVE_LSTAT) && !defined(lstat)]: Remove.
+       (SA_NOCLDSTOP, sigprocmask, sigset_t) [!defined SA_NOCLDSTOP]:
+       New macros.
+       (siginterrupt) [!defined SA_NOCLDSTOP && ! HAVE_SIGINTERRUPT]:
+       New macro.
+       (HAVE_WORKING_O_NOFOLLOW): Define to 0 if not defined.
+       (caught_signals, exiting_signal, remove_ofname_fd): New vars.
+       (remove_ofname): Remove; all uses changed to remove_ofname_fd.
+       (same_file, name_too_long): Remove.
+       (install_signal_handlers): New function.  It prefers sigaction,
+       which is more reliable in the presence of race conditions.
+       Catch SIGXCPU and SIGXFSZ, too.
+       (main): Use it instead of installing them by hand.
+       (treat_file): Check for read error when closing ifd.
+       (treat_file, create_outfile, remove_output_file):
+       Avoid race conditions with signals.
+       (create_outfile, check_ofname): Remove most of the gorp about
+       working around ENAMETOOLONG deficiencies.  It's obsolete now, and
+       anyway it had race conditions.  Just rely on O_EXCL and
+       ENAMETOOLONG.  The worst that can happen is that a file name will
+       be silently truncated on an obsolete machine, but no data will be lost.
+       (open_and_stat): Use HAVE_WORKING_O_NOFOLLOW rather than O_NOFOLLOW
+       to work around some O_NOFOLLOW bugs.  Otherwise, fall back on
+       lstat only if lstat is available, as symlinks don't exist otherwise.
+       (open_input_file): Use O_NONBLOCK and O_NOCTTY too, to avoid
+       hanging gzip on special files.
+       (abort_gzip_signal): If sigaction is not available, ignore
+       signals.  If we get the exiting signal, exit with ERROR status
+       rather than raising a signal.
+       * tailor.h (NO_ST_INO): Remove; no longer used now that same_file
+       is gone.
+
+2006-12-05  Paul Eggert  <eggert@cs.ucla.edu>
+
+       Port to Tandem NSK/OSS, which lacks fchdir.  Problem reported by
+       Matthew Woehlke in
+       <http://lists.gnu.org/archive/html/bug-gzip/2006-11/msg00013.html>.
+       * bootstrap.conf (gnulib_modules): Remove openat, as it pulls in
+       fchdir.
+       * configure.ac: Check for fdopendir.
+       * gzip.c: Don't include openat.h; no longer needed.
+       (treat_dir) [!HAVE_FDOPENDIR]: Fall back on the old opendir method
+       since fdopendir is not available.
+
 2006-12-04  Paul Eggert  <eggert@cs.ucla.edu>
 
        * NEWS: Describe the following change briefly.