come into compliance with Perl policy
[debian/amanda] / ChangeLog
index a37ffb6261fa3ed2268e00063d908612dedffec4..01db0a1abb3a54323b6b6d92ac53d031b59f4a3f 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,344 @@
+2009-11-05  Jean-Louis Martineau <martineau@zmanda.com>
+        * client-src/sendbackup-dump.c, client-src/sendsize.c,
+          client-src/selfcheck.c:
+         Fix compiler error if VXDUMP or VDUMP is defined.
+
+2009-11-05  Jean-Louis Martineau <martineau@zmanda.com>
+       * client-src/client_util.c: close FILE instead of fd.
+       * client-src/selfcheck.c: fix fd leak with app_stderr.
+
+2009-10-29  Jean-Louis Martineau <martineau@zmanda.com>
+       * client-src/sendsize.c: Fix error reporting.
+
+2009-10-27  Jean-Louis Martineau <martineau@zmanda.com>
+       * packaging/deb/rules, packaging/deb/buildpkg,
+         packaging/rpm/buildpkg,
+         packaging/rpm/amanda.spec: Change version to 2.6.1p2.
+       * NEWS: Add news for 2.6.1p2.
+       * configure.in: Change version to 2.6.1p2.
+
+2009-10-27  Jean-Louis Martineau <martineau@zmanda.com>
+       * perl/Amanda/Application/Zfs.pm: Use diskname for the snapshot name.
+
+2009-10-23  Jean-Louis Martineau <martineau@zmanda.com>
+       * device-src/tape-device.c: handle EROFS in open.
+
+2009-10-08  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/tape-device.h: add missing field
+
+2009-10-07 Dan Locks <dwlocks@zmanda.com>
+       *  packaging/deb/control: add |gnuplot-nox
+
+2009-10-07  Dustin J. Mitchell <dustin@zmanda.com>
+       * man/xml-source/amanda-devices.7.xml: add NONBLOCKING_OPEN property
+       * config/amanda/tape.m4: use DEFAULT_TAPE_NON_BLOCKING_OPEN by default
+         on Linux
+       * device-src/tape-device.c device-src/tape-device.h: conditionalize
+         the use of a nonblocking open
+
+2009-10-07  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/diskfile.c: Fix initialization of xml_app.result.
+
+2009-08-31  Dustin J. Mitchell <dustin@zmanda.com>
+       * restore-src/amrestore.c: call device_configure
+
+2009-08-31 Dan Locks <dwlocks@zmanda.com>
+       * packaging/rpm/amanda.spec: add amstar and amgtar to suid section of
+         %files for server.
+
+2009-08-13  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/amtapetype.pl: fix bad merge of references to
+         Amanda:Header
+
+2009-08-05 Dan Locks <dwlocks@zmanda.com>
+       * Thanks to Jim Barber for pointing out these bugs.
+       * packaging/deb/amanda-backup-client.postinst, packaging/deb/rules,
+         packaging/deb/amanda-backup-server.postinst: replace all instances
+         of AMHOMEDIR with AMANDAHOMEDIR, install .am_passphrase 0600.
+       * packaging/deb/control: add build-depends for libglib2.0-dev
+
+2009-07-24  Jean-Louis Martineau <martineau@zmanda.com>
+       * amandad-src/amandad.c: Fix fd allocation.
+
+2009-07-16  Jean-Louis Martineau <martineau@zmanda.com>
+       * changer-src/chg-lib.sh.in: Fix MESSAGE parsing for Solaris sed.
+
+2009-06-19  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/reporter.c: Use the filenum from the PART line.
+                                Keep the filenum of the first part.
+
+2009-06-12  Jean-Louis Martineau <martineau@zmanda.com>
+       * amandad-src/amandad.c: Fix for configured with CLIENT_LOGIN=root
+       * man/xml-source/amanda-client.conf.5.xml: Typo.
+       * man/xml-source/amanda.conf.5.xml: Add ssh_keys.
+
+2009-05-22  Jean-Louis Martineau <martineau@zmanda.com>
+       * restore-src/amfetchdump.c: Fix sort_needed_tapes_by_write_timestamp.
+
+2009-05-22  Jean-Louis Martineau <martineau@zmanda.com>
+       * client-src/sendbackup.c: Compatibity with 2.4.2 server.
+
+2009-05-15  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/driver.c: Fix crash in amflush.
+
+2009-05-15  Jean-Louis Martineau <martineau@zmanda.com>
+       * common-src/debug.c: Fix memory leak.
+
+2009-05-07  Dustin J. Mitchell <dustin@zmanda.com>
+           Jean-Louis Martineau <martineau@zmanda.com>
+       * common-src/debug.c: do not use a mutex in debug_printf
+       * common-src/pipespawn.c server-src/changer.c:
+         do not call debug_printf after fork()
+
+2009-05-06  Dustin J. Mitchell <dustin@zmanda.com>
+       * server-src/taper.c: check for division by zero and don't print 'nan'
+         for kbps
+       * installcheck/taper.pl: don't expect 'nan'
+
+2009-05-04  Dustin J. Mitchell <dustin@zmanda.com>
+       * server-src/taper-mem-port-source.c
+         server-src/taper-disk-port-source.c: continue reading from the port
+         after the cache is exhausted, instead of terminating the part abruptly
+         (which can lead to insertion of spurious zeros into the dumpfile);
+         also remove some unnecessary assertions (g_return_val_if_fail)
+       * server-src/taper-file-source.c: use correct unit on part size;
+         correctly calculate estimated number of parts
+       * server-src/taper-port-source.c: replace assertion with 'if'
+
+2009-04-27  Jean-Louis Martineau <martineau@zmanda.com>
+       * client-src/sendbackup.c: Fix dbprintf statements.
+
+2009-04-22  Sam Couter <sam@couter.id.au>
+       * changer-src/chg-glue.pl: return a helpful error message when
+         Amanda::Changer->new() fails
+
+2009-04-21  Jean-Louis Martineau <martineau@zmanda.com>
+       * man/xml-source/amanda-devices.7.xml: Add 'FSF_AFTER_FILEMARK'
+         property to 'tape:' driver.
+       * device-src/tape-device.c: Add code for new 'FSF_AFTER_FILEMARK'
+         property, set is_eof to FLASE where needed.
+       * device-src/tape-device.h: Add fsf_after_filemark to _TapeDevice.
+       * device-src/tape-aix.c, device-src/tape-uware.c,
+         device-src/tape-xenix.c, device-src/tape-posix.c: Set default value
+         for FSF_AFTER_FILEMARK.
+       * config/amanda/defaults.m4: Find default value for 'FSF_AFTER_FILEMARK'
+         property.
+       * xfer-src/dest-null.c: Remove bogus assert.
+       * device-src/amtapetype.pl: New -p option to discover driver properties,
+         it can find value for the 'FSF_AFTER_FILEMARK' property.
+       * man/xml-source/amtapetype.8.xml: Document -p options
+
+2009-04-20  Jean-Louis Martineau <martineau@zmanda.com>
+       * device-src/tape-device.c: handle EROFS in open.
+
+2009-04-17  Nikolas Coukouma <atrus@zmanda.com>
+       * device-src/device.c: fix error message for unparsable property
+
+2009-04-15  Dustin J. Mitchell <dustin@zmanda.com>
+       * restore-src/amfetchdump.c: keep the order of tapes within a
+         particular run of Amanda
+
+2009-04-10  Dustin J. Mitchell <dustin@zmanda.com>
+       * common-src/conffile.c: fix handling of double-backslash in quoted
+         strings
+
+2009-04-09  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/dumper.c: Check authopt before using it.
+
+2009-04-07  Jean-Louis Martineau <martineau@zmanda.com>
+       * client-drc/sendbackup.c: Init result.
+
+2009-04-07  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/taper-source.c (default_taper_source_seek_to_part_start):
+         returns FALSE on not splitted dump.
+       * server-src/driverio.c: info.last_level should not be set on error
+                        if level >= info.last_level.
+       * server-src/driver.c: Rename update_failed_dump_to_tape to
+         update_failed_dump.
+         Call update_failed_dump on failed dump to holding disk.
+       * application-src/amgtar.c: Don't update statefile if the backup failed.
+       * client-drc/sendbackup.c: Don't update amandates if backup failed.
+
+2009-04-03  Dustin J. Mitchell <dustin@zmanda.com>
+       * perl/Amanda/Changer/compat.pm: always configure devices while
+         scanning
+       * server-src/amcheckdump.pl: configure devices returned from the
+         changer
+
+2009-04-01  Nikolas Coukouma <atrus@zmanda.com>
+       * device-src/s3.c: don't send empty location constraint,
+         allocate error messages
+
+2009-04-01  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/s3-device.c: always send errors from setup_handle
+
+2009-04-01  Nikolas Coukouma <atrus@zmanda.com>
+       * device-src/s3-device.c: don't clobber errors from setup_handle
+
+2009-03-31  Jean-Louis Martineau <martineau@zmanda.com>
+        * server-src/amcheck.c: Set l on error path.
+
+2009-03-31  Jean-Louis Martineau <martineau@zmanda.com>
+       * perl/Amanda/Changer/compat.pm: Don't import :logging from Debug.
+
+2009-03-30  Jean-Louis Martineau <martineau@zmanda.com>
+       * packaging/deb/changelog, packaging/deb/rules,
+       * packaging/deb/buildpkg, packaging/rpm/buildpkg,
+       * packaging/rpm/amanda.spec: Change version to 2.6.1p1.
+       * NEWS: Add news for 2.6.1p1.
+       * configure.in: Change version to 2.6.1p1.
+
+2009-03-29  Dan Locks <dwlocks@zmanda.com>
+       * packaging/rpm/amanda.spec: change a number of %if conditionals to
+         macros which expand if they are defined.
+
+2009-03-25  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/s3.c: fix segfault in s3_make_bucket with location
+         constraint
+
+2009-03-19  Dustin J. Mitchell <dustin@zmanda.com>
+       (thanks to Peter Kunst <peter.kunst@swissrisk.com>)
+       * common-src/Makefile.am: don't include genversion.h in distribution
+         tarballs
+
+2009-03-19  Dustin J. Mitchell <dustin@zmanda.com>
+       * xfer-src/Makefile.am: add -release to libamxfer
+
+2009-03-17  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/amlabel.c: give correct exit status on failure
+
+2009-03-13  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/amstatus.pl: dump in "writing to tape" mode should also
+                                 be included in the "dumped" summary.
+
+2009-03-13  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/find.c: Fix listing of partial dump in holding disk.
+
+2009-03-12  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/planner.c: Log quoted qname.
+
+2009-03-11  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/amtapetype.pl: do not produce broken 'bytes' units
+       * installcheck/amtapetype.pl: test changes
+       * man/xml-source/amanda.conf.5.xml: tapetype:length is not in bytes!
+       * common-src/conffile.c: fix default for tapetype:length
+
+2009-03-11  Dustin J. Mitchell <dustin@zmanda.com>
+       * common-src/amfeatures.c: improve error handling in
+         am_string_to_feature, return NULL on error
+       * amandad-src/amandad_util.c recover-src/amrecover.c
+         server-src/amcheck.c server-src/amindexd.c server-src/chunker.c
+         server-src/driver.c server-src/dumper.c server-src/planner.c: always
+         terminate the string passed to am_string_to_feature
+
+2009-03-11  Dustin J. Mitchell <dustin@zmanda.com>
+       * common-src/amfeatures.c: fix am_string_to_feature to fail correctly
+         on a bad feature string
+
+2009-03-10  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/taper.c: return DONE if input file is partial.
+
+2009-03-10  Dustin J. Mitchell <dustin@zmanda.com>
+       * common-src/conffile.c: Set default TAPETYPE_FILEMARK to 1.
+
+2009-02-27  Jean-Louis Martineau <martineau@zmanda.com>
+       * application-src/amgtar.c: Fix parsing of EXIT-HANDLING property.
+
+2009-02-24  Dustin J. Mitchell <dustin@zmanda.com>
+       * changer-src/chg-rait.sh: get directory handling right (patch from
+         Jim.pennino on wiki.zmanda.com)
+       * changer-src/chg-glue.pl: produce a debug log, add do_clean, fix
+         do_eject
+       * perl/Amanda/Changer.pm: Add a new chg->eject method, to eject a
+         volume that's not currently reserved
+       * perl/Amanda/Changer/compat.pm: fix release(), don't load 'current'
+         after cleaning or ejecting
+       * installcheck/Amanda_Changer_compat.pl: updated tests
+
+2009-02-24  Jean-Louis Martineau <martineau@zmanda.com>
+       * amandad-src/amandad.c, application-src/amgtar.c,
+         changer-src/scsi-changer-driver.c, client-src/client_util.c,
+         common-src/conffile.c, device-src/s3-device.c,
+         oldrecover-src/set_commands.c, recover-src/set_commands.c,
+         server-src/amindexd.c, server-src/planner.c,
+         server-src/reporter.c: Replace all occurences of index by strchr,
+                                Replace all occurences of rindex by strrchr.
+
+2009-02-24  Nikolas Coukouma <atrus@zmanda.com>
+       * device-src/s3.c: make s3_list_keys use its own buffer
+
+2009-02-24  Nikolas Coukouma <atrus@zmanda.com>
+       * device-src/s3.c: fix error buffer handling of overflow data
+
+2009-02-23  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/rait-device.c: actually *report* mismatched child
+         labels/timestamps; correctly detect the 'first' device; and free old
+         device label/time
+
+2009-02-23  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/vfs-device.c: remove bogus locking stubs that are
+         making syscalls like close(-1); fix error handling in read_label
+         if check_is_dir fails()
+
+2009-02-19  Dustin J. Mitchell <dustin@zmanda.com>
+       * perl/Amanda/Changer/compat.pm: add missing semicolon in do_release
+
+2009-02-18  John Hein <jhein@timing.com>
+       * common-src/dgram.c: set the send buffer size when creating a new
+         socket
+
+2009-02-17  Dustin J. Mitchell <dustin@zmanda.com>
+       * restore-src/amfetchdump.c: remove unintended debugging messages
+
+2009-02-17  Jean-Louis Martineau <martineau@zmanda.com>
+       * changer-src/chg-manual.sh: make messages clearer
+       * perl/Amanda/Changer/compat.pm: use _run_tpchanger directly from
+         _manual_scan
+       * server-src/amcheckdump.pl: handle errors better
+
+2009-02-09  Dustin J. Mitchell <dustin@zmanda.com>
+       * man/xml-source/amanda.conf.5.xml: remove TODO
+
+2009-02-07  Dustin J. Mitchell <dustin@zmanda.com>
+       * common-src/event.c: use built-in child watch source on FreeBSD
+
+2009-02-06  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/dumper.c: options is already unquoted.
+       * common-src/util.c: argument should not be quoted when added to argv.
+
+2009-02-06  Dustin J. Mitchell <dustin@zmanda.com>
+       * installcheck/Amanda_Changer_compat.pl: remove debugging code
+
+2009-02-06  Jean-Louis Martineau <martineau@zmanda.com>
+       patch by Yoshihiro Ishikawa
+       * recover-src/extract_list.c: Handle application-api.
+
+2009-02-06  Dustin J. Mitchell <dustin@zmanda.com>
+       * installcheck/Amanda_Changer_compat.pl: support 'eject'
+       * perl/Amanda/Changer.pm: change release/do_relase relationship
+       * perl/Amanda/Changer/compat.pm: same
+       * perl/Amanda/Changer/disk.pm: same
+       * perl/Amanda/Changer/single.pm: same
+
+2009-01-13  Dustin J. Mitchell <dustin@zmanda.com>
+       * perl/Amanda/Paths.pm.in: add $localstatedir
+       * server-src/amserverconfig.pl: remove extraneous /
+
+2009-02-04  Jean-Louis Martineau <martineau@zmanda.com>
+       * amplot/amplot.awk: Set term to x11.
+
+2009-02-02  Jean-Louis Martineau <martineau@zmanda.com>
+       * common-src/conffile.c: Correctly copy pp_scriptlist.
+
+2009-02-02  Dustin J. Mitchell <dustin@zmanda.com>
+       * config/config.guess config/config.sub: new updates from FSF
+       * autogen: fix quoting error
+       * config/amanda/dumpers.m4:  use a hostname we're more confident
+         doesn't exist
+
+2009-01-30  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/amstatus.pl: Remove a bogus line.
+
 2009-01-22  Jean-Louis Martineau <martineau@zmanda.com>
        * configure.in: AM_INIT_AUTOMAKE(amanda, "2.6.1")
        * packaging/deb/rules, packaging/deb/buildpkg, packaging/deb/changelog,