make maintainer-clean removes these, and we want a clean orig.tar.gz
[debian/gnuradio] / gr-howto-write-a-block / configure.ac
index 7790c69b0738eb9e79e19557f178f1c9f92aad6a..52c4639bb544c83b1281faa730845de8f96b431d 100644 (file)
@@ -1,11 +1,11 @@
 dnl 
 dnl 
-dnl  Copyright 2004,2005 Free Software Foundation, Inc.
+dnl  Copyright 2004,2005,2007,2008,2009 Free Software Foundation, Inc.
 dnl  
 dnl  This file is part of GNU Radio
 dnl  
 dnl  GNU Radio is free software; you can redistribute it and/or modify
 dnl  it under the terms of the GNU General Public License as published by
 dnl  
 dnl  This file is part of GNU Radio
 dnl  
 dnl  GNU Radio is free software; you can redistribute it and/or modify
 dnl  it under the terms of the GNU General Public License as published by
-dnl  the Free Software Foundation; either version 2, or (at your option)
+dnl  the Free Software Foundation; either version 3, or (at your option)
 dnl  any later version.
 dnl  
 dnl  GNU Radio is distributed in the hope that it will be useful,
 dnl  any later version.
 dnl  
 dnl  GNU Radio is distributed in the hope that it will be useful,
@@ -15,90 +15,74 @@ dnl  GNU General Public License for more details.
 dnl  
 dnl  You should have received a copy of the GNU General Public License
 dnl  along with GNU Radio; see the file COPYING.  If not, write to
 dnl  
 dnl  You should have received a copy of the GNU General Public License
 dnl  along with GNU Radio; see the file COPYING.  If not, write to
-dnl  the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl  Boston, MA 02111-1307, USA.
+dnl  the Free Software Foundation, Inc., 51 Franklin Street,
+dnl  Boston, MA 02110-1301, USA.
 dnl 
 
 dnl 
 
+
 AC_INIT
 AC_PREREQ(2.57)
 AC_INIT
 AC_PREREQ(2.57)
-AC_CONFIG_SRCDIR([src/lib/howto.i])
-AM_CONFIG_HEADER(config.h)
-AC_CANONICAL_TARGET([])
-AM_INIT_AUTOMAKE(gr-howto-write-a-block,0.6cvs)
-
-GR_X86_64
-dnl LF_CONFIGURE_CC
-LF_CONFIGURE_CXX
-LF_SET_WARNINGS
-GR_SET_GPROF
-GR_SET_PROF
-GR_PROG_AS
-AC_PROG_LN_S
-AC_PROG_MAKE_SET
-AC_PROG_INSTALL
-
-AC_LIBTOOL_WIN32_DLL
-AC_ENABLE_SHARED       dnl do build shared libraries
-AC_DISABLE_STATIC      dnl don't build static libraries
-AC_PROG_LIBTOOL
-
-dnl Locate python, SWIG, etc
-GR_NO_UNDEFINED
-GR_SCRIPTING
-
-dnl Checks for libraries.
+AC_CONFIG_AUX_DIR([.]) 
 
 
-dnl check for threads (mandatory)
-GR_OMNITHREAD
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
+AC_CANONICAL_TARGET
 
 
-CFLAGS="${CFLAGS} $PTHREAD_CFLAGS"
-CXXFLAGS="${CXXFLAGS} $PTHREAD_CFLAGS"
+GR_VERSION
+dnl ustar required to have pathnames > 99 chars
+_AM_SET_OPTION([tar-ustar])
+AM_INIT_AUTOMAKE(gr-howto-write-a-block,$RELEASE)
 
 
-if test "x$CXX_FOR_BUILD" = x
-then
-  CXX_FOR_BUILD=${CXX}
-fi
-AC_SUBST(CXX_FOR_BUILD)
+dnl This is kind of non-standard, but it sure shortens up this file :-)
+m4_include([config/gr_standalone.m4])
+GR_STANDALONE
 
 
-dnl Checks for header files.
-AC_HEADER_STDC
-AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(fcntl.h limits.h strings.h sys/ioctl.h sys/time.h unistd.h)
-AC_CHECK_HEADERS(sys/mman.h)
+dnl Check for any libraries you need
+dnl AC_CHECK_LIBRARY
 
 
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-AC_C_INLINE
-AC_TYPE_SIZE_T
-AC_HEADER_TIME
+dnl Check for header files you need
+dnl AC_CHECK_HEADERS(fcntl.h limits.h strings.h sys/ioctl.h sys/time.h unistd.h)
+dnl AC_CHECK_HEADERS(sys/mman.h)
 
 dnl Checks for library functions.
 
 dnl Checks for library functions.
-AC_CHECK_FUNCS([])
+dnl AC_CHECK_FUNCS([])
+
+dnl We pick up the boost cppflags, cxxflags and thread lib via GNURADIO_CORE
+dnl
+dnl If you need additional boost libraries, you'll need to
+dnl uncomment AX_BOOST_BASE, plus some of the following:
+dnl
+dnl calls AC_SUBST(BOOST_CPPFLAGS), AC_SUBST(BOOST_LDFLAGS) and defines HAVE_BOOST
+dnl AX_BOOST_BASE([1.35])
+dnl
+dnl All the rest of these call AC_SUBST(BOOST_<foo>_LIB) and define HAVE_BOOST_<foo>
+dnl
+dnl AX_BOOST_DATE_TIME
+dnl AX_BOOST_FILESYSTEM
+dnl AX_BOOST_IOSTREAMS
+dnl AX_BOOST_PROGRAM_OPTIONS
+dnl AX_BOOST_REGEX
+dnl AX_BOOST_SERIALIZATION
+dnl AX_BOOST_SIGNALS
+dnl AX_BOOST_SYSTEM
+dnl AX_BOOST_TEST_EXEC_MONITOR
+dnl AX_BOOST_UNIT_TEST_FRAMEWORK
+dnl AX_BOOST_WSERIALIZATION
 
 
-dnl Check for Mingw support
-GR_PWIN32
-
-PKG_CHECK_MODULES(GNURADIO_CORE, gnuradio-core >= 2)
-LIBS="$LIBS $GNURADIO_CORE_LIBS"
-
-dnl Define where to find boost includes
-dnl defines BOOST_CFLAGS
-GR_REQUIRE_BOOST_INCLUDES
-
-STD_DEFINES_AND_INCLUDES="$GNURADIO_CORE_CFLAGS $BOOST_CFLAGS"
-AC_SUBST(STD_DEFINES_AND_INCLUDES)
 AC_CONFIG_FILES([\
          Makefile \
 AC_CONFIG_FILES([\
          Makefile \
+         apps/Makefile \
          config/Makefile \
          config/Makefile \
-         doc/Makefile \
-         src/Makefile \
-         src/lib/Makefile \
-         src/python/Makefile \
-         src/python/run_tests \
+         grc/Makefile \
+         lib/Makefile \
+         python/Makefile \
+         python/run_tests \
+         swig/Makefile \
        ])
 
 dnl run_tests is created from run_tests.in.  Make it executable.
        ])
 
 dnl run_tests is created from run_tests.in.  Make it executable.
-AC_CONFIG_COMMANDS([run_tests], [chmod +x src/python/run_tests])
+AC_CONFIG_COMMANDS([run_tests], [chmod +x python/run_tests])
 
 AC_OUTPUT
 
 AC_OUTPUT
+
+echo Configured gr-howto-write-a-block release $RELEASE for build.