cobble a temporary changelog entry to keep this test build straight
[debian/gnuradio] / config / grc_usrp.m4
index b9740aea7bb455c6e1884ed1157e0172611c6f2f..999b9c5c331b7db74b87e217bc6d5859685b0aba 100644 (file)
@@ -22,8 +22,8 @@ AC_DEFUN([GRC_USRP],[
 
     GRC_WITH(usrp)
 
 
     GRC_WITH(usrp)
 
-    dnl Don't do usrp if omnithread skipped
-    GRC_CHECK_DEPENDENCY(usrp, omnithread)
+    dnl Don't do usrp if gruel is skipped
+    GRC_CHECK_DEPENDENCY(usrp, gruel)
 
     dnl Make sure the fast usb technique is set, OS dependent.
     dnl This is always performed, since it puts out CLI flags.
 
     dnl Make sure the fast usb technique is set, OS dependent.
     dnl This is always performed, since it puts out CLI flags.
@@ -45,7 +45,7 @@ AC_DEFUN([GRC_USRP],[
         AC_CHECK_FUNCS([sigaction snprintf])
 
        dnl Make sure libusb version is installed; required for legacy USB
         AC_CHECK_FUNCS([sigaction snprintf])
 
        dnl Make sure libusb version is installed; required for legacy USB
-        USRP_LIBUSB([$req_libusb1],[passed=no;AC_MSG_RESULT([Unable to find dependency libusb.])])
+        USRP_LIBUSB([$req_libusb1],[],[passed=no;AC_MSG_RESULT([Unable to find dependency libusb.])])
 
        dnl Make sure SDCC >= 2.4.0 is available.
         USRP_SDCC([2.4.0],[],[passed=no;AC_MSG_RESULT([Unable to find firmware compiler SDCC.])])
 
        dnl Make sure SDCC >= 2.4.0 is available.
         USRP_SDCC([2.4.0],[],[passed=no;AC_MSG_RESULT([Unable to find firmware compiler SDCC.])])
@@ -59,18 +59,6 @@ AC_DEFUN([GRC_USRP],[
         usrp_LA="\${abs_top_builddir}/usrp/host/lib/libusrp.la"
     fi
 
         usrp_LA="\${abs_top_builddir}/usrp/host/lib/libusrp.la"
     fi
 
-    dnl There pkg-config file for usrp requires omnithread for Darwin only.  Create a variable
-    dnl for just the usrp.pc.in case.
-    case "$host_os" in
-      darwin*)
-        usrp_darwin_omnithread_pc_requires="gnuradio-omnithread"
-        ;;
-      *) dnl (blanks)
-        usrp_darwin_omnithread_pc_requires=""
-        ;;
-    esac
-    AC_SUBST(usrp_darwin_omnithread_pc_requires)
-
     AC_CONFIG_FILES([ \
        usrp/Makefile \
        usrp/usrp.pc \
     AC_CONFIG_FILES([ \
        usrp/Makefile \
        usrp/usrp.pc \