Allowing PFB interpolator to be called without specifying the taps; autogen taps...
[debian/gnuradio] / config / grc_usrp.m4
index 3708dcad0d28eeceb6c1fdb27ffab51652393c48..999b9c5c331b7db74b87e217bc6d5859685b0aba 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006,2007,2008 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2007,2008,2009 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -20,12 +20,10 @@ dnl Boston, MA 02110-1301, USA.
 AC_DEFUN([GRC_USRP],[
     GRC_ENABLE(usrp)
 
 AC_DEFUN([GRC_USRP],[
     GRC_ENABLE(usrp)
 
-    GRC_WITH(usrp, [GRC_WITH_PKG_CONFIG_CHECK(usrp-inband)])
+    GRC_WITH(usrp)
 
 
-    dnl Don't do usrp if omnithread, mblock, or pmt skipped
-    GRC_CHECK_DEPENDENCY(usrp, omnithread)
-    GRC_CHECK_DEPENDENCY(usrp, mblock)
-    GRC_CHECK_DEPENDENCY(usrp, pmt)
+    dnl Don't do usrp if gruel is skipped
+    GRC_CHECK_DEPENDENCY(usrp, gruel)
 
     dnl Make sure the fast usb technique is set, OS dependent.
     dnl This is always performed, since it puts out CLI flags.
 
     dnl Make sure the fast usb technique is set, OS dependent.
     dnl This is always performed, since it puts out CLI flags.
@@ -46,59 +44,36 @@ AC_DEFUN([GRC_USRP],[
         AC_CHECK_FUNCS([getrusage sched_setscheduler pthread_setschedparam])
         AC_CHECK_FUNCS([sigaction snprintf])
 
         AC_CHECK_FUNCS([getrusage sched_setscheduler pthread_setschedparam])
         AC_CHECK_FUNCS([sigaction snprintf])
 
-       dnl Don't do usrp if guile not available (inband requires it)
-       GRC_CHECK_GUILE(usrp)
-
-       dnl Make sure libusb is installed; required for legacy USB
-        USRP_LIBUSB([],[passed=no;AC_MSG_RESULT([Unable to find dependency libusb.])])
+       dnl Make sure libusb version is installed; required for legacy USB
+        USRP_LIBUSB([$req_libusb1],[],[passed=no;AC_MSG_RESULT([Unable to find dependency libusb.])])
 
        dnl Make sure SDCC >= 2.4.0 is available.
         USRP_SDCC([2.4.0],[],[passed=no;AC_MSG_RESULT([Unable to find firmware compiler SDCC.])])
     fi
     if test $passed != with; then
        dnl how and where to find INCLUDES and LA
 
        dnl Make sure SDCC >= 2.4.0 is available.
         USRP_SDCC([2.4.0],[],[passed=no;AC_MSG_RESULT([Unable to find firmware compiler SDCC.])])
     fi
     if test $passed != with; then
        dnl how and where to find INCLUDES and LA
-       usrp_INCLUDES="-I\${abs_top_srcdir}/usrp/host/lib/legacy \
-               -I\${abs_top_srcdir}/usrp/firmware/include \
-               -I\${abs_top_builddir}/usrp/host/lib/legacy"
-        usrp_LA="\${abs_top_builddir}/usrp/host/lib/legacy/libusrp.la"
-       usrp_inband_INCLUDES="-I\${abs_top_srcdir}/usrp/host/lib/inband"
-       usrp_inband_LA="\${abs_top_builddir}/usrp/host/lib/inband/libusrp-inband.la"
+       usrp_INCLUDES=" \
+               -I\${abs_top_srcdir}/usrp/host/include \
+               -I\${abs_top_builddir}/usrp/host/include \
+               -I\${abs_top_srcdir}/usrp/firmware/include"
+        usrp_LA="\${abs_top_builddir}/usrp/host/lib/libusrp.la"
     fi
 
     fi
 
-    dnl Include the usrp-inband INCLUDES and LA
-    AC_SUBST(usrp_inband_INCLUDES)
-    AC_SUBST(usrp_inband_LA)
-
-    dnl There are 2 pkg-config files (usrp, and usrp-inband); the one
-    dnl for usrp requires omnithread for Darwin only.  Create a variable
-    dnl for just the usrp.pc.in case.
-    case "$host_os" in
-      darwin*)
-        usrp_darwin_omnithread_pc_requires="gnuradio-omnithread"
-        ;;
-      *) dnl (blanks)
-        usrp_darwin_omnithread_pc_requires=""
-        ;;
-    esac
-    AC_SUBST(usrp_darwin_omnithread_pc_requires)
-
     AC_CONFIG_FILES([ \
        usrp/Makefile \
        usrp/usrp.pc \
     AC_CONFIG_FILES([ \
        usrp/Makefile \
        usrp/usrp.pc \
-       usrp/usrp-inband.pc \
         usrp/usrp.iss \
         usrp/doc/Doxyfile \
         usrp/doc/Makefile \
         usrp/doc/other/Makefile \
         usrp/host/Makefile \
         usrp/usrp.iss \
         usrp/doc/Doxyfile \
         usrp/doc/Makefile \
         usrp/doc/other/Makefile \
         usrp/host/Makefile \
+       usrp/host/include/Makefile \
+       usrp/host/include/usrp/Makefile \
         usrp/host/misc/Makefile \
         usrp/host/lib/Makefile \
         usrp/host/misc/Makefile \
         usrp/host/lib/Makefile \
-        usrp/host/lib/inband/Makefile \
-        usrp/host/lib/legacy/Makefile \
-        usrp/host/lib/legacy/std_paths.h \
+        usrp/host/lib/std_paths.h \
         usrp/host/swig/Makefile \
         usrp/host/apps/Makefile \
         usrp/host/swig/Makefile \
         usrp/host/apps/Makefile \
-        usrp/host/apps-inband/Makefile \
         usrp/firmware/Makefile \
         usrp/firmware/include/Makefile \
         usrp/firmware/lib/Makefile \
         usrp/firmware/Makefile \
         usrp/firmware/include/Makefile \
         usrp/firmware/lib/Makefile \
@@ -107,6 +82,8 @@ AC_DEFUN([GRC_USRP],[
         usrp/firmware/src/usrp2/Makefile \
         usrp/fpga/Makefile \
         usrp/fpga/rbf/Makefile \
         usrp/firmware/src/usrp2/Makefile \
         usrp/fpga/Makefile \
         usrp/fpga/rbf/Makefile \
+        usrp/fpga/rbf/rev2/Makefile \
+        usrp/fpga/rbf/rev4/Makefile \
     ])
 
     GRC_BUILD_CONDITIONAL(usrp)
     ])
 
     GRC_BUILD_CONDITIONAL(usrp)