Improved performance of FLL using a more robust error term.
[debian/gnuradio] / config / grc_mblock.m4
index a8fba4e03ccedd4e1dd00aa48e7c75b8df945eb9..e3ae1817f10966882e4b0ffd7e1837048d53d0a9 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -18,27 +18,41 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_MBLOCK],[
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_MBLOCK],[
-    GRC_ENABLE([mblock])
+    GRC_ENABLE(mblock)
+
+    GRC_WITH(mblock)
+
+    dnl Don't do mblock if omnithread or pmt skipped
+    GRC_CHECK_DEPENDENCY(mblock, pmt)
+    GRC_CHECK_DEPENDENCY(mblock, omnithread)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+       dnl Don't do mblock if guile not available
+       GRC_CHECK_GUILE(mblock)
+    fi
+    if test $passed != with; then
+       dnl how and where to find INCLUDES and LA
+       mblock_INCLUDES="-I\${abs_top_srcdir}/mblock/src/include"
+        mblock_LA="\${abs_top_builddir}/mblock/src/lib/libmblock.la"
+    fi
 
     AC_CONFIG_FILES([\
 
     AC_CONFIG_FILES([\
-       mblock/Makefile \
-       mblock/doc/Makefile \
-       mblock/src/Makefile \
-       mblock/src/lib/Makefile
+        mblock/Makefile \
+        mblock/mblock.pc \
+        mblock/doc/Makefile \
+        mblock/src/Makefile \
+       mblock/src/include/Makefile \
+       mblock/src/include/mblock/Makefile \
+        mblock/src/lib/Makefile \
+        mblock/src/scheme/Makefile \
+        mblock/src/scheme/gnuradio/Makefile \
     ])
 
     ])
 
-    passed=yes
-    # Don't do mblock if pmt skipped
-    # There *has* to be a better way to check if a value is in a string
-    for dir in $skipped_dirs
-    do
-       if test x$dir = xpmt; then
-           AC_MSG_RESULT([Component mblock requires pmt, which is not being built.])
-           passed=no
-       fi
-    done
-
-    GRC_BUILD_CONDITIONAL([mblock],[
+    GRC_BUILD_CONDITIONAL(mblock,[
         dnl run_tests is created from run_tests.in.  Make it executable.
        dnl AC_CONFIG_COMMANDS([run_tests_mblock], [chmod +x mblock/src/python/run_tests])
     ])
         dnl run_tests is created from run_tests.in.  Make it executable.
        dnl AC_CONFIG_COMMANDS([run_tests_mblock], [chmod +x mblock/src/python/run_tests])
     ])