Add flags and dependencies for MinGW/MSYS.
[debian/gnuradio] / config / grc_gr_usrp.m4
index 5039f5245959e46691e53afbc68bd749f21b4d98..1f2cd1ac73deab6af7a296eae40fded307bf1bbb 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -14,30 +14,25 @@ dnl GNU General Public License for more details.
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
 dnl 
 dnl You should have received a copy of the GNU General Public License
 dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_USRP],[
 
 AC_DEFUN([GRC_GR_USRP],[
-    GRC_ENABLE([gr-usrp])
+    GRC_ENABLE(gr-usrp)
+
+    dnl Don't do gr-usrp if usrp or gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-usrp, usrp)
+    GRC_CHECK_DEPENDENCY(gr-usrp, gnuradio-core)
 
     AC_CONFIG_FILES([ \
 
     AC_CONFIG_FILES([ \
-        gr-usrp/Makefile \
-        gr-usrp/src/Makefile \
-        gr-usrp/src/run_tests \
+        gr-usrp/Makefile \
+       gr-usrp/gnuradio-usrp.pc \
+        gr-usrp/src/Makefile \
+        gr-usrp/src/run_tests \
+       gr-usrp/apps/Makefile \
     ])
 
     ])
 
-    passed=yes
-    # Don't do gr-usrp if usrp skipped
-    # There *has* to be a better way to check if a value is in a string
-    for dir in $skipped_dirs
-    do
-       if test x$dir = xusrp; then
-           AC_MSG_RESULT([Component gr-usrp requires usrp, which is not being built.])
-           passed=no
-       fi
-    done
-
-    GRC_BUILD_CONDITIONAL([gr-usrp],[
+    GRC_BUILD_CONDITIONAL(gr-usrp,[
        dnl run_tests is created from run_tests.in.  Make it executable.
        AC_CONFIG_COMMANDS([run_tests_usrp], [chmod +x gr-usrp/src/run_tests])
     ])
        dnl run_tests is created from run_tests.in.  Make it executable.
        AC_CONFIG_COMMANDS([run_tests_usrp], [chmod +x gr-usrp/src/run_tests])
     ])