build: update version number to 3.3.1
[debian/gnuradio] / config / grc_gr_sounder.m4
index a821ce4ad545006fb85198e227fe4ef57c05fb52..672d13ab1315fb33b7521e7c827a88478892adec 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2007 Free Software Foundation, Inc.
+dnl Copyright 2007,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -18,32 +18,26 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_SOUNDER],[
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_SOUNDER],[
-    GRC_ENABLE([gr-sounder])
+    GRC_ENABLE(gr-sounder)
+
+    dnl Don't do gr-sounder if usrp or gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-sounder, usrp)
+    GRC_CHECK_DEPENDENCY(gr-sounder, gnuradio-core)
 
     AC_CONFIG_FILES([ \
 
     AC_CONFIG_FILES([ \
-        gr-sounder/Makefile \
-        gr-sounder/doc/Makefile \
-        gr-sounder/src/Makefile \
-        gr-sounder/src/fpga/Makefile \
-        gr-sounder/src/fpga/top/Makefile \
-         gr-sounder/src/fpga/lib/Makefile \
-        gr-sounder/src/fpga/rbf/Makefile \
-        gr-sounder/src/lib/Makefile \
-        gr-sounder/src/python/Makefile \
-         gr-sounder/src/python/run_tests
+        gr-sounder/Makefile \
+        gr-sounder/doc/Makefile \
+        gr-sounder/src/Makefile \
+        gr-sounder/src/fpga/Makefile \
+        gr-sounder/src/fpga/top/Makefile \
+        gr-sounder/src/fpga/lib/Makefile \
+        gr-sounder/src/fpga/tb/Makefile \
+        gr-sounder/src/lib/Makefile \
+        gr-sounder/src/python/Makefile \
+        gr-sounder/src/python/run_tests
     ])
 
     ])
 
-    passed=yes
-    # Don't do gr-sounder if usrp skipped
-    for dir in $skipped_dirs
-    do
-       if test x$dir = xusrp; then
-           AC_MSG_RESULT([Component gr-sounder requires usrp, which is not being built.])
-           passed=no
-       fi
-    done
-
-    GRC_BUILD_CONDITIONAL([gr-sounder],[
+    GRC_BUILD_CONDITIONAL(gr-sounder,[
        dnl run_tests is created from run_tests.in.  Make it executable.
        AC_CONFIG_COMMANDS([run_tests_sounder], [chmod +x gr-sounder/src/python/run_tests])
     ])
        dnl run_tests is created from run_tests.in.  Make it executable.
        AC_CONFIG_COMMANDS([run_tests_sounder], [chmod +x gr-sounder/src/python/run_tests])
     ])