prepare to upload
[debian/gnuradio] / config / grc_gr_gsm_fr_vocoder.m4
index 84a4a61bacd92ddafa4b4c96d6d2ae976f1ab0fc..941cb25577f7de3f34bbe3ed8896b84a5502e31e 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -18,19 +18,21 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_GSM_FR_VOCODER],[
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_GSM_FR_VOCODER],[
-    GRC_ENABLE([gr-gsm-fr-vocoder])
+    GRC_ENABLE(gr-gsm-fr-vocoder)
+
+    dnl Don't do gr-gsm-fr-vocoder if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-gsm-fr-vocoder, gnuradio-core)
 
     AC_CONFIG_FILES([\
 
     AC_CONFIG_FILES([\
-       gr-gsm-fr-vocoder/Makefile \
-       gr-gsm-fr-vocoder/src/Makefile \
-       gr-gsm-fr-vocoder/src/lib/Makefile \
-       gr-gsm-fr-vocoder/src/lib/gsm/Makefile \
-       gr-gsm-fr-vocoder/src/python/Makefile \
-       gr-gsm-fr-vocoder/src/python/run_tests \
+        gr-gsm-fr-vocoder/Makefile \
+        gr-gsm-fr-vocoder/src/Makefile \
+        gr-gsm-fr-vocoder/src/lib/Makefile \
+        gr-gsm-fr-vocoder/src/lib/gsm/Makefile \
+        gr-gsm-fr-vocoder/src/python/Makefile \
+        gr-gsm-fr-vocoder/src/python/run_tests \
     ])
 
     ])
 
-    passed=yes
-    GRC_BUILD_CONDITIONAL([gr-gsm-fr-vocoder],[
+    GRC_BUILD_CONDITIONAL(gr-gsm-fr-vocoder,[
         dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_gsm], [chmod +x gr-gsm-fr-vocoder/src/python/run_tests])
     ])
         dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_gsm], [chmod +x gr-gsm-fr-vocoder/src/python/run_tests])
     ])